Closed Bug 511889 Opened 10 years ago Closed 10 years ago

uploads for Fennec builds should include langpacks/deb packages

Categories

(Release Engineering :: General, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: willyaranda, Assigned: aki)

References

Details

(Whiteboard: [fennec l10n][l10n])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; es-ES; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: 

It could be very useful for localizers to have xpis to test the translation of Fennec.

I know that there are localized builds for fennec, both on 1.9.2 and trunk, so I think it is not too difficult to upload those xpis.

Maybe it could be in the same folder, or on a xpi folder inside the folder where builds are put

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [fennec l10n][l10n]
Axel, is it fine to future it for now? I can get it assigned to me but I will not revisit it until the end of September.
We do generate those xpis, we apparently just don't upload them. This should be fixed soon, it should really just be a matter of making the upload pieces picking up another item.
Is there a reason why we're not using upload.py for mobile builds?
(In reply to comment #4)
> Is there a reason why we're not using upload.py for mobile builds?

It didn't exist when when they were setup IIRC.
Morphing this bug to upload not just the tarball, but all of the localized fennec bits.

Once we get debs up, we'll need to upload those, too. Same for whatever turns out to be the wince installer.
Summary: Provide langpacks for Fennec builds → uploads for Fennec builds should include langpacks/deb packages
Depends on: 490482
Blocks: 513761
Futuring until someone has time to pick this up - maybe a q4 goal?
Component: Release Engineering → Release Engineering: Future
This is required for shipping Fennec.
Taking unless another Releng could take it. Any expected delivery time? Next week or can it wait few weeks?
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
Status: NEW → ASSIGNED
Assignee: nobody → armenzg
Priority: P3 → P2
I believe this will just be a change to packageGlob in mobile_l10n_nightly_factory in mobile_master.py.  I can take a look tomorrow.
Bug 502759 means that old XPIs and tarballs will sit in the dist/ directory, and upload with the built files.

Assuming we continue with the packageGlob method of uploading, this will be needed.  That depends on the status of https://bugzilla.mozilla.org/show_bug.cgi?id=502759#c1

Not setting the review flag since this seems to be in a state of flux.  But if we need it, I've tested this method in staging.

Patch 1 of 2.
The second part of the patch.

This is incomplete since I don't know the name or location of the deb, so I haven't added that. (dependent on bug 490482)

However, this will upload the xpi.
Priority: P2 → P3
Reassigning as discussed last week on IRC
Assignee: armenzg → aki
Attachment #400584 - Flags: review?(ccooper)
Attachment #400582 - Flags: review?(ccooper)
Comment on attachment 400582 [details] [diff] [review]
fix bug 502759, which will break xpi uploads

Just curious why this patch isn't in bug 502759? ;)
Attachment #400582 - Flags: review?(ccooper) → review+
Attachment #400584 - Flags: review?(ccooper) → review+
Comment on attachment 400582 [details] [diff] [review]
fix bug 502759, which will break xpi uploads

That's what They would be expecting, isn't it? ;-)

Checked in:
http://hg.mozilla.org/build/buildbotcustom/rev/6013eb249c1f
Attachment #400582 - Flags: checked-in+
Comment on attachment 400584 [details] [diff] [review]
add the xpi to maemo/linux fennec desktop l10n repack packageGlob

http://hg.mozilla.org/build/buildbot-configs/rev/15d33eb72736
Attachment #400584 - Flags: checked-in+
The xpi should upload now. Waiting for the deb.
I'm going to close this out.
l10n deb creation is tracked in bug 490482 ; if/when that gets fixed, the upload should be part of that fix.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.