Cursor should be pointer when over open Sidebar tab

VERIFIED WORKSFORME

Status

P3
trivial
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: knocte, Assigned: matt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000902
BuildID:    2000090208

If in My Sydebar, like in my case, we only have the Bookmarks tab active, when
we pass the cursor over the word Bookmarks, the cursor becomes a "finger
pointing" cursor, and this is not useful because we cannot do anything if we
left-click or right-click.

Reproducible: Always
Steps to Reproduce:
1.Have on My Sidebar only active the Bookmarks tab.
2.Go with the mouse over the word "Bookmarks" on My Sidebar.

Actual Results:  The cursor changes to a "pointing finger" cursor type, and
there is no functionality if we click with any mouse button.


Expected Results:  Remain the same type of cursor although the mouse is over the
word "Bookmarks".

Comment 1

18 years ago
This isn't online with the Bookmarks tab, but with all of them. I don't know if
this is a problem or a WONTFIX.
-> Sidebar
Component: Bookmarks → Sidebar
QA Contact: claudius → shrir

Comment 2

18 years ago
I don't think it matters much either way, but confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Why hand cursor over Bookmarks on My Sidebar? → Cursor should be pointer when over open Sidebar tab

Comment 3

18 years ago
I think my problem falls into the same category.  This is on Linux with the CVS
sources as of last night (2000-09-08) and quite some time before.

If you move the cursor from the the main window, passing the slider are drag
button one of the following happens:

- if you pass the button the cursor changes to the pointing hand and stays like
  this in the sidebar

- if instead the mouse is passing only the border of the sidebar (where you
  can drag but not collapse) the cursor changes to the left-right arrows
  and stays like this

- if you do either with sufficiently high speed the cursor stays the same as
  in the main window (means it remains to be the normal arrow)

- as soon as the mouse is moved up to the tabs of the sidebar (I have the
  bookmark tab open, so that there is none below) the cursor changes to the
  correct normal arrow


While I could leave with either the normal arrow or the hand, the left-right
arrows are annoying since I never can remember where the hot spot of this
cursor is.

Comment 4

18 years ago
hey guys,

This is a very recent regression from I think the patch for bug 5693.  I noticed
that all my links with :hover no longer work with a pointer while links without
:hover render the pointer correctly.

I think the component should be event handling for this bug and depends on
fixing the patch for bug 5693.

I will report the broken cursor in 5693.  Should be an easy fix...

Comment 5

18 years ago
Opps wrong bug :-).

Sorry about the SPAM.

Comment 6

18 years ago
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → matt

Comment 7

18 years ago
I'm not seeing this bug, but it sounds very similar to bug 26585.

Comment 8

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
(Reporter)

Comment 9

18 years ago
I think we could close this bug because now in Mozilla 0.9.1 2001060703 (WinME),
I place the mouse pointer over the word "Bookmarks" on My Sidebar and the cursor
doesn't change to a "finger pointing" cursos.
Can anyone verify this?

Comment 10

17 years ago
Worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 11

17 years ago
marking verified...reopen if it still does not work. provide reproducible test
case.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.