The default bug view has changed. See this FAQ.

Recognize and parse RFC 822 dates that use "Z" as a timezone

RESOLVED FIXED in Firefox 11

Status

()

Firefox
RSS Discovery and Preview
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: D, Assigned: philor)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 11
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

The date of some feeds is not displayed while the date is RFC 822.
For example, "Mon, 24 Aug 2009 19:15:00 Z" is RFC 822 compliant and is validated by feedvalidator.org, but it's not displayed when the feed is displayed whith Firefox

Reproducible: Always

Steps to Reproduce:
1. Open the Ars Technica feed given as a URL
Actual Results:  
The date is not displayed

Expected Results:  
The date yould be parsed and displayed
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
I get the same problem with Windows XP:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090825 Namoroka/3.6a2pre (.NET CLR 3.5.30729) ID:20090825052618
Status: UNCONFIRMED → NEW
Component: General → RSS Discovery and Preview
Ever confirmed: true
OS: Windows 7 → All
QA Contact: general → rss.preview
Hardware: x86 → All
(Reporter)

Comment 2

7 years ago
Should I set Firefox or Toolkit as the Product ?
(Assignee)

Updated

6 years ago
Depends on: 682781
(Assignee)

Updated

5 years ago
Summary: RSS date (<pubDate>) parser is not compliant with RFC 822 → Recognize and parse RFC 822 dates that use "Z" as a timezone
Version: 3.5 Branch → Trunk
(Assignee)

Comment 3

5 years ago
Created attachment 575808 [details] [diff] [review]
Perhaps excessive

This version is maybe a little over the top, but it's what I was thinking in bug 677135 comment 9 when I was thinking about using this as documentation for how to massage dates.
Attachment #575808 - Flags: review?(mak77)
(Assignee)

Comment 4

5 years ago
Created attachment 575809 [details] [diff] [review]
Much less

Less pedantic, probably more reasonable.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #575809 - Flags: review?(mak77)
Comment on attachment 575809 [details] [diff] [review]
Much less

Review of attachment 575809 [details] [diff] [review]:
-----------------------------------------------------------------

The verbose approach is something you may be proud for the next 10 years, but then someone could make you sad doing a code cleanup.  Since I don't want you to be sad, I'll accept this simpler approach :p
Attachment #575809 - Flags: review?(mak77) → review+

Updated

5 years ago
Flags: in-testsuite+

Updated

5 years ago
Attachment #575808 - Attachment is obsolete: true
Attachment #575808 - Flags: review?(mak77)
Ah, please, just add a reference to bug 682781 in the comment.
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/38d6d2ac55e7
Target Milestone: --- → Firefox 11
https://hg.mozilla.org/mozilla-central/rev/38d6d2ac55e7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.