Document objects should always implement HTMLDocument and SVGDocument per HTML5

RESOLVED DUPLICATE of bug 897815

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 897815
9 years ago
2 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

({html5})

Trunk
html5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 396715 [details]
Test case as application/xml

Build ID:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090826 Minefield/3.7a1pre

Steps to reproduce:
 1) Load the first one of the attached test cases.

Actual results:
document implements Document but not HTMLDocument or SVGDocument.

Expected results:
Expected document to implement Document, HTMLDocument and SVGDocument in all three test cases.

Additional info quoted from HTML5:
"All Document objects (in user agents implementing this specification) must also implement the HTMLDocument  interface, available using binding-specific methods. (This is the case whether or not the document in question is an HTML document or indeed whether it contains any HTML elements at all.) Document objects must  also implement the document-level interface of any other namespaces found in the document that the UA supports.

For example, if an HTML implementation also supports SVG, then the Document object implements both HTMLDocument and SVGDocument."
(Reporter)

Comment 1

9 years ago
Created attachment 396716 [details]
Test case as application/xhtml+xml
(Reporter)

Comment 2

9 years ago
Created attachment 396717 [details]
Test case as image/svg+xml
(Reporter)

Comment 3

9 years ago
See also bug 383983.
We should do this.

Updated

7 years ago
Blocks: 383983
Keywords: dev-doc-needed

Updated

7 years ago
Blocks: 349308

Updated

6 years ago
Blocks: 718711
Latest spec requires that the interfaces be merged.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897815
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.