Closed Bug 512779 Opened 10 years ago Closed 9 years ago

Style pinstripe theme splitters like Thunderbird

Categories

(Calendar :: Lightning Only, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: martinschroeder, Assigned: Fallen)

References

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(2 files, 2 obsolete files)

Follow-up from bug 485890: Splitters in Thunderbird on MacOS X are different form the winstripe ones.
Component: General → Lightning Only
QA Contact: general → lightning
Assignee: mschroeder → nobody
Status: ASSIGNED → NEW
Attached patch Fix - v1 โ€” โ€” Splinter Review
This brings the mac theme on par with Thunderbird, including splitters. Decathlon, I'd appreciate a code-level review, you don't have to test this.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #513493 - Flags: review?
Attachment #513493 - Flags: review? → review?(bv1578)
We should take this for the beta, the mac theme looks horrible without! This also fixes bug 412272, at least the mac part of it.
Whiteboard: [needed beta][no l10n impact][needs review]
Duplicate of this bug: 543967
Duplicate of this bug: 635592
As noted in bug 635592, I will add lines to fix the close icon in the unifinder. I've already done this locally so it will be fixed for checkin.
Comment on attachment 513493 [details] [diff] [review]
Fix - v1

I can't find nothing wrong in the patch, but it depends mostly on the look that it allows to get.
Without testing, I suppose that, e.g., every "-moz-image-region" attribute is correct according to the related "-moz-image-region" image in particular for new images.
r+
Attachment #513493 - Flags: review?(bv1578) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/59e01ab2fabd>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
OS: Mac OS X → All
Resolution: --- → FIXED
Whiteboard: [needed beta][no l10n impact][needs review] → [needed beta][no l10n impact]
Target Milestone: --- → Trunk
Backported to comm-1.9.2 <http://hg.mozilla.org/releases/comm-1.9.2/rev/93d4ed6e03fa>
Target Milestone: Trunk → 1.0b3
(In reply to comment #6)
> Comment on attachment 513493 [details] [diff] [review]
> Fix - v1
> 
> Without testing, I suppose that, e.g., every "-moz-image-region" attribute is
> correct according to the related "-moz-image-region" image in particular for
> new images.

Unfortunately, changes to calendar/base/themes/common/calendar-task-tree.css break checkboxes in Lightning at least on Linux (but should break on Windows as well), because checkbox-images.png for pinstripe is 64x16, but for winstripe only 52x13 pixel.
Attached patch Move checkbox image rules into themes (obsolete) โ€” โ€” Splinter Review
I have no idea how stupid or evil this is, but this avoids the collision of incompatible -moz-image-region rules.
In general you're going in the right direction, but the calendar-task-view.css is meant for the actual task view tab. I guess we can park the css there for now, but actually I was aiming to do something in bug 533096, i.e


winstripe/calendar-task-view.css containing:

@import url(chrome://calendar/skin/common/calendar-daypicker.css);

...


and then have the xul files import chrome://calendar/skin/calendar-daypicker.css as usual. I guess we can start with this file here, but I'm happy to take the hack fix too. If you want to take over, go ahead. Otherwise I'll put together a patch in the next days.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This hackish quick band-aid doesn't misuse calendar-task-view.css but renames common/calendar-task-tree.css into common/calendar-task-tree-common.css and restores @THEME@/calendar-task-tree.css for theme-specific styling. Maybe a simple partial revert of <http://hg.mozilla.org/comm-central/rev/e64b897de57a> concerning task tree would have been cleaner.

> but actually I was aiming to do something in bug 533096, i.e
> 
> winstripe/calendar-task-view.css containing:
> 
> @import url(chrome://calendar/skin/common/calendar-daypicker.css);
> 
> ...
> 
> and then have the xul files import
> chrome://calendar/skin/calendar-daypicker.css as usual.

I'm only starting to read about XUL, thus minor easy CSS adjustments are all I am able to contribute now, but if you do this, I'll watch and learn.
This just borrows from <https://bugzilla.mozilla.org/attachment.cgi?id=416280> to provide a quick fix for the checkbox breakage.

It took longer for me to understand that I don't have to touch any .xul and .xml files, my apologies.

The patch has been successfully tested on Linux.
Attachment #517135 - Attachment is obsolete: true
Attachment #517240 - Attachment is obsolete: true
Comment on attachment 517249 [details] [diff] [review]
Move checkbox image rules back into themes v3

Great, this was exactly what I was looking for, r=philipp. For the next patch, when you feel it is ready to be looked over, set the review flag to ? and enter a reviewer (this can be anyone from the calendar team, if in doubt then me, Decathlon reviews mostly UI stuff like this).
Attachment #517249 - Flags: review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/9adffca33dd7>
Backported to comm-1.9.2 <http://hg.mozilla.org/releases/comm-1.9.2/rev/147a40112aae>

-> FIXED
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: 1.0b3 → 1.0b2
Target Milestone: 1.0b2 → 1.0b3
You need to log in before you can comment on or make changes to this bug.