Enhancement: Give users the option to "restart" current session and reload all current tabs and windows

RESOLVED DUPLICATE of bug 414961

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 414961
9 years ago
9 years ago

People

(Reporter: spockmay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WONTFIX?])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090825 Namoroka/3.6a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090825 Namoroka/3.6a2pre

Frequently while using the Adobe Flash plugin under Linux the plugin simply stops responding.  It doesn't crash, but you can no longer view Flash files.  In these cases you can bookmark all tabs and then close and reopen all the tabs, or set the browser.sessionstore.resume_session_once flag to "true" via about:config.  Rather than these workarounds, it would be nice if there was a menu entry that duplicates the functionality of the resume_session_once flag.  Something like File > Restart

Reproducible: Always
I'm going to guess this is a WONTFIX which we'll leave to add-on space. In fact this is likely a dupe.

What I usually do is File|Exit and get the prompt (make sure you have prompt when closing multiple tabs) which then lets me decide when I'm quitting if I want to restore my session (this just flips the resume_session_once pref).

AMO https://addons.mozilla.org/en-US/firefox/search/?q=restart
Whiteboard: [WONTFIX?]

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414961
You need to log in before you can comment on or make changes to this bug.