Closed Bug 513033 Opened 11 years ago Closed 4 years ago

Enter key doesn't work in Location bar (likely AVG toolbar even after blocklisting)

Categories

(Plugins Graveyard :: AVG AV, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: cww, Unassigned)

Details

See: bug 475653

Going through old common issues bugs, came across two reports of still having this exact problem (also likely caused by AVG) even after we blocklisted.

https://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=413223&forumId=1

https://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=408729&forumId=1

Can we confirm that we blocklisted all the versions that cause problems?
I was about to ask the same question, unless this is a new addon/outside software causing this.

2 users came in #firefox on irc.mozilla.org saying they had this problem.

User #1 said he was on 3.0.7 on the AIX OS. But I didn't get a chance to ask him about addons. He said he couldn't type anything but one character in the location bar and the search bar, enter key didn't work either.

User #2 said they were on 3.0.6,: 
I had Firefox 3.06 on Slackware 12.2, it seemed to be working ok, then today it worked ok for a while then no matter whether I closed firefox and restart or not, I cannot enter text into the address bar or into a search field e.g. Google's search field. I thought maybe it was a bug in the older version of Firefox so I upgraded it to 3.0.13. Still no luck.

Other relevant information is that I can select Home which takes me to google.com with the mouse, then move the mouse to the address bar, highlight the text and press the delete key and it works. If I then try and type in a URL I get no response. No add ons at all other than whatever was configured by Slackware's packagers (default plugin, gxine, java plugin & SVG plugins)

I'm very doubtful AVG even makes anything for linux.
http://support.mozilla.com/en-US/forum/1/481453 suggests it's happening again.
So I have installed the newest AVG 9 release on XP and tried to reproduce this problem with Firefox 3.5.3. Sadly I cannot get it in the state where it blocks my return key in the location bar or any other search bar.

All the support articles are a bit older. So probably the problem was part of an older release of AVG. Since v9 has been released lately it would be interesting to know if people with that version are affected too.
I have now installed Firefox 3.5.5 and activating AVG Safe Search 9.0.0.696 enter key doesn't work. The problem exists also with Firefox 3.5.3.
Gian, that is the free version of AVG with the version 8.5, right? Have you made an upgrade from an older version of AVG? Further do you have installed other add-ons? If yes, do the issue also happen when only AVG Safe Search is enabled?  Have you already tried a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
Hi, AVG has released a new free version for its antivirus (version 9).
I made the update downloading the latest files available from AVG site and not directly for the program. The error appears also with a new profile and with only AVG Safe Search add-on enabled.
I have also installed:
BitDefender quickscanner
Brief
Dizionario italiano (Italian dictionary)
Java quick starter
Microsoft .NET Framework Assistant
Multirowbookmarkstoolbar
PDF creator toolbar
ReloadEvery

I know that the same problem existed with the previous version of AVG Safe Search.

I forgoto to say that disabling AVG SAfe Search everything is OK.
We're now tracking such bugs. This doesn't mean it's something we can fix, merely something we hope to be able to point vendors to so they can investigate. This is an automated message.
Component: Extension Compatibility → AVG AV
Product: Firefox → Plugins
QA Contact: extension.compatibility → avg-antivirus
Version: 3.5 Branch → unspecified
I have mozilla 10.0.2 and AVG free 2012.0.1913
on XP SP3 x86

I had same issue, Enter did not work in address bar, but it worked in quick search bar.
Disabling AVG link scanner, complete AVG and AVG safe search ADD-ON did not help to solve the problem.

I solved it by reinstalling mozilla firefox. Uninstall and download again. I kept all history and passwords.
Closing old bugs in the Plugins component. We aren't going to track issues in 3rd-party plugins in the Mozilla bug tracker. In addition, support for NPAPI plugins will be removed at the end of this year; for more details see the post at https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

If there is a serious bug in Firefox, it needs to be filed in the "Core" product, "Plug-Ins" component.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.