Closed Bug 475653 Opened 11 years ago Closed 11 years ago

Enter button does not work in address bar, due to AVG Safe Search

Categories

(Plugins Graveyard :: AVG AV, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: srs965, Unassigned)

References

Details

(Keywords: common-issue-)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090127 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090127 Minefield/3.2a1pre ID:20090127103633

The enter button is not working for the address bar. It worked fine for the first 1 or 2 weeks. Now, it only goes to the typed address if I click the green arrow button.

Reproducible: Always

Steps to Reproduce:
1.Type an address into the address bar
2.Press Enter

Actual Results:  
Nothing happens, does not go until you click the green arrow.

Expected Results:  
Load the page specified in the address bar.
Do you have any add-ons installed?  If so, which one(s)?  Have you tried running in Safe Mode?

http://support.mozilla.com/en-US/kb/Safe+Mode
I have Adblock Plus, AutoPager, AVG Safe Search, Bookmark Previws, Greasemonkey, Nightly Tester Tools and Smart Digg Button Installed. Safe mode does not have any effect.
I have Adblock Plus, AutoPager, AVG Safe Search, Bookmark Previws,
Greasemonkey, Nightly Tester Tools and Smart Digg Button Installed. Safe mode
does not have any effect.
Does anything relevant show up in Tools | Error Console?
no, it's completely blank
IIRC other users were complaining about this issue due to AVG safe search
Disabling that fixed the problem, thank you.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Summary: Enter button does not work in address bar → Enter button does not work in address bar, due to AVG Safe Search
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
I also have the same problem. It just started happening in my Firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090202 Firefox/3.1a1pre Ubiquity/0.1.5)
AVG Update just recently told me I needed to restart my PC to complete the installation of the latest update. The 'enter' key failed to work in the URL bar after that.
Disabling AVG Safe Search 8.0 fixes the problem so I will try and find how to post a bug report to AVG now.
(In reply to comment #8)
> I also have the same problem. It just started happening in my Firefox
> (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090202
> Firefox/3.1a1pre Ubiquity/0.1.5)
> Disabling AVG Safe Search 8.0 fixes the problem so I will try and find how to
> post a bug report to AVG now.

What is the version/build of AVG 8?
AVG version  8.0.233 Licence: Free
I posted this information to the AVG Bug forum but the moderator deleted my post just now!!
What is the point in a Bug forum if the AVG moderator Randy 'rdsok' thinks my comments are worth deleting? I am spending my time trying to make both AVG and Firefox a better product and it gets deleted. Next time I will just uninstall AVG instead.
The link was:
http://freeforum.avg.com/read.php?14,168756,backpage=,sv=
Duplicate of this bug: 476583
Duplicate of this bug: 477035
Duplicate of this bug: 478011
Keywords: common-issue+
--> Extension Compatibility

Kev: can you contact AVG?

Are people who are reporting this problem running without extension compatibility version checks (extensions.checkCompatibility = false)? Or has AVG not set their maxVer correctly?
Status: VERIFIED → UNCONFIRMED
Component: Location Bar and Autocomplete → Extension Compatibility
QA Contact: location.bar → extension.compatibility
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3.1?
AVG contacted, requested contacts on the dev team to work towards resolving this. I'll update the bug when I have additional information.
I did have extensions.checkCompatibility = false but have now changed it to true, restarted firefox, re-enabled the addon and restarted firefox again.
Problem still occurs.

Does the extension maxver check only happen when the extension is first installed?

AVG has been on the cc list for this problem since last week.
Richard: did you also edit the MaxVersion in the extensions install.rdf (in C:\Program Files\AVG\AVG8\Firefox) to 3.0.*? the default it uses is 3.*. As-shipped that will cause it to be reported as compatible with 3.1. I performed the steps you outlined with an edited plugin and could not replicate the issue you outline. My result was the plugin was disabled on restart.

Missed the grisoft email addresses.
No I hadn't edited that file.
I just checked and my install.rdf is showing <em:maxVersion>3.*</em:maxVersion>
I had a look into C:\Program Files\AVG\AVG8\Firefox\Chrome\searchshield\content\overlay.js
It appears that this problem occurs when the onURLBarEntered function is reached.
It gets to the end of that function and then it is supposed to return handleURLBarCommand(e); but then nothing happens.
What tools or config settings do I need to debug this? Can I step through the code into the handleURLBarCommand function?  Was just using alerts just now to check where in the function it was reaching.

When user clicks the 'go' button the onURLBarEntered function is not called and the page loads correctly.
If press enter or select from dropdown then just get white screen.
(In reply to comment #19)
> It gets to the end of that function and then it is supposed to return
> handleURLBarCommand(e); but then nothing happens.

This needs to be gURLBar.handleCommand(e);
If there's a problem with communicating this to AVG, we can also add handleURLBarCommand back.
Yes that worked.
I also realised that the function was also stopping at an earlier point when it tries to execute the canonizeUrl function. I forgot I had commented out that line earlier while debugging.

	// cleanup url
	var postData = {};
	canonizeUrl(e, postData);
	alert("i never get here");

Commenting out that line appears to let everything work fine.
Duplicate of this bug: 478323
Just as a follow-on, I've nominated version 8.0 of the safesearch plugin for blocklisting in 3.1 and higher. I understand there are a couple AVG folks on this thread, and if you could drop me a line with who I should send info to in the product management group on what this means, it'd be appreciated. Please ensure that any 3.1 compatible patch that is released has the plugin version incremented from 8.0.
I disabled AVG Safe Search from the Tools -> Add-ons -> Extensions . Now the problem has been solved.

Thanks guys. But AVG needs to fix this bug ASAP.
Just FYI, this is already fixed and the program update is waiting in the pipeline. I will try to push it out OOB.
This bug doesn't block 3.1; Kev, can you nominate the blocklisting one, though?
Flags: blocking-firefox3.1? → blocking-firefox3.1-
for meeting and investigation by Tracy, since the issue has been found as due to AVG, and AVG has a possible fix in queue, i'm resolving this as INVALID due to not being a bug in Firefox.
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → INVALID
The new version of AVG 8.5 has been released. The installation files are available on the AVG web site, the program updates will be released later this week. The new AVG version is 8.5.276 and contains the fix for this bug.
Sorry for the trouble.
Petr, thanks for the fix and notification of it
Duplicate of this bug: 481075
Duplicate of this bug: 477971
Kev nominated v8.0 to be blocklisted. Is that still moving forward? https://bugzilla.mozilla.org/show_bug.cgi?id=475653#c23
Duplicate of this bug: 481160
the new version of AVG DOES fix the address bar issue, however, the search bar still suffers the same...!  ie you type your search query, press ENTER and... nothing... even clicking the magnifying glass doesn't work, youy need to manually go to google/yahoo etc first to do the search
We are not able to to confirm or reproduce the Sarch bar problem. It worked even before.
Can anyone else, please?
(In reply to comment #34)
Can you try resetting your toolbars and controls in safe mode http://support.mozilla.com/en-US/kb/Safe+Mode check Reset Toolbars and Controls and then click restart Firefox.

(This will remove toolbar customizations.)
Hi everyone... This issue has been resolved with AVG Free 8.5...
(In reply to comment #36)
> (In reply to comment #34)
> Can you try resetting your toolbars and controls in safe mode
> http://support.mozilla.com/en-US/kb/Safe+Mode check Reset Toolbars and Controls
> and then click restart Firefox.
> 
> (This will remove toolbar customizations.)

have tried this but still the same. safe mode with all add-ons disabled and it's the same... are there any files i can post anywhere that may help troubleshoot?

by the way, i have already upgraded to avg 8.5 which resolved the main address bar issue but not the search bar...

MaFt
I can confirm that using NT 6.x with FF 3.1B2, I updated to AVG 8.5.278 and found that the search bar doesn't work, as the AVG Safe Search is the only thing as an add-on and disabled.  The address bar worked.  

I then enabled AVG Safe Search, did a restart.  FF updated to 3.1b3.  The AVG Safe Search is enabled and the search bar works.  The Address bar works as well.  

So take your pick.  I know I confirmed the Search Bar's behavior didn't work when after just updating AVG to 8.5 as in Comment #38, but once re-enabling the AVG Safe Search Add-on, both the Address and Search bars do work, but couldn't determine if the Beta 3 changed anything here.

It also appears that AVG's Web Shield functionality is also permanently disabled on my PC, It won't turn on (not sure it's relevance).

From a glance I'd still say this is resolved regardless, so I'd recommend for comment #38, trying either to Enable the 8.5 Safe Search add-on and/or updating to Beta 3 outta resolve the issue.
Duplicate of this bug: 483253
Duplicate of this bug: 483447
Duplicate of this bug: 483562
Duplicate of this bug: 483666
Duplicate of this bug: 483605
Duplicate of this bug: 483927
Hey everyone -

This bug is about AVG causing problems with the location bar. There are reports of the Search Bar not responding to enter in bug 441510, please go there to discuss that issue - unclear at this point if it's AVG causing it or not, but your input would be appreciated!

Also, for those looking to track the blocklisting of AVG < 8.5 for Firefox 3.1, that's bug 479095
Disabling AVG Safe Search from the Tools -> Add-ons -> Extensions and then restarting firefox fixed this issue for me. 

Thanks guys. But I AVG really needs to fix this bug ASAP.
Duplicate of this bug: 484507
Duplicate of this bug: 484640
Thanks guys, I did the same "Disabling AVG Safe Search from the Tools -> Add-ons -> Extensions " and it is start working for me. I also want to add one more thing, in case "green arrow " also stop working nothing happened on click on it, so i need to use the search bar to open the page(i know it is funny :)).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

AW u guys rocks :)
Duplicate of this bug: 485408
Duplicate of this bug: 485735
Duplicate of this bug: 486450
Duplicate of this bug: 486439
Duplicate of this bug: 485957
Duplicate of this bug: 486897
Status: RESOLVED → VERIFIED
Duplicate of this bug: 488208
Duplicate of this bug: 488308
Duplicate of this bug: 483561
Duplicate of this bug: 490415
Duplicate of this bug: 491533
This bug also occurs when using firefox 3.5 with Vista OS
(In reply to comment #62)
This bug has been closed, I filed a new bug 513033 in case we missed blocklisting a ..version or something
We're now tracking such bugs. This doesn't mean it's something we can fix, merely something we hope to be able to point vendors to so they can investigate. This is an automated message.
Component: Extension Compatibility → AVG AV
Flags: blocking-firefox3.5-
Product: Firefox → Plugins
QA Contact: extension.compatibility → avg-antivirus
Version: Trunk → unspecified
I have mozilla 10.0.2 and AVG free 2012.0.1913
on XP SP3 x86

I had same issue, Enter did not work in address bar, but it worked in quick search bar.
Disabling AVG link scanner, complete AVG and AVG safe search ADD-ON did not help to solve the problem.

I solved it by reinstalling mozilla firefox. Uninstall and download again. I kept all history and passwords.

Now it works OK
Same issue. Firefox 10.0.2 and AVG free 2011 10.0.1424 here.
Disabling AVG did not help. I will try reinstalling Firefox.
Just in case anybody lands here with a similar problem, as I did (FF 15.0.1, AVG SS 10.0.0.1423, AVG ST 12.2.5.32) I may have a solution. Both of the AVG extensions were already disabled in my browser, so obviously disabling them couldn't fix it, but resetting all of the AVG entries in about:config and restarting the browser fixed the problem.
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.