Closed Bug 51323 Opened 21 years ago Closed 20 years ago

Should allow drags from bg windows

Categories

(Core :: XUL, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

RESOLVED FIXED
mozilla0.9.7

People

(Reporter: sfraser_bugs, Assigned: mikepinkerton)

References

Details

(Keywords: helpwanted, Whiteboard: needs r/sr)

Attachments

(1 file, 1 obsolete file)

If I drag and drop into a background window (e.g. a composer window), the 
destination window should come to the front.

Likewise, I should be able to drag out of a background window...
Yup.  sigh...  ->future
Target Milestone: --- → Future
4.x doesn't bring the window dropped into to the frontmost, neither does the 
Finder.

yes, we do need to be able to drag from a bg window, but i was thinking a bit 
about this this weekend and it's non-trivial, well maybe it is...we'd have to 
wait to bring the window to the fg on a mouse up, etc.

changing summary to reflect what we want this bug to be.
Keywords: helpwanted
Summary: Drop in background window show bring the window to the front → Should allow drags from bg windows
I'm not sure we'd want to bring a bg window source to fg during the drag, since
that can obscure the intended dest.  In any case, we'll have to think a bit more
about what behavior we want.
Drag from background window is bug 38646 (at least for Windows).

What happened to the other part of this bug, bringing the dragged-into window 
to the front (on Mac only?) ?
i don't know of any app that brings the dragged-into window to the fg on mac.
And apple's HIG say that you don't activate BG windows: see the PDF doc at:
http://developer.apple.com/techpubs/macos8/InterproCom/DragManager/
dragmanager.html
cc brade
ok, you win. IE and word both do this. *shrug*. it's still future.
Target Milestone: Future → mozilla0.9
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9 → mozilla0.9.1
Target Milestone: mozilla0.9.1 → mozilla0.9.2
->0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3
ok, have a patch, needs r/sr/a
Whiteboard: needs r/sr/a
I smell tabs in that patch.
Would it be possible to fix this bug and bug 38646 (allow drags from bg windows 
on all platforms) at the same time, or is a platform-specific fix needed for 
Mac?
Target Milestone: mozilla0.9.3 → mozilla0.9.4
*** Bug 92520 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla0.9.4 → mozilla0.9.5
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Target Milestone: mozilla0.9.6 → mozilla0.9.7
this patch works much better than the last one (besides being updated for the
new event sink stuff). it draws the hilighted link in the background so the
user knows what they're dragging. it also prevents click-hold context menus
from coming up on the bg window if the user lingers too long.
Attachment #39642 - Attachment is obsolete: true
new patch needing r/sr. I'll detab the entire file before i check it in. Ignore
the fact that there are tabs/spaces mixed in the patch.
Whiteboard: needs r/sr/a → needs r/sr
Comment on attachment 60527 [details] [diff] [review]
updated patch that works better

sr=sfraser
Attachment #60527 - Flags: superreview+
Comment on attachment 60527 [details] [diff] [review]
updated patch that works better

r=sdagley (and I really hate braces on the same line as the conditional but I
seem to be in the minority on that :-)
Attachment #60527 - Flags: review+
fixed
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.