It's possible to scroll the main page sideways even though there is no scroll bar

RESOLVED DUPLICATE of bug 516259

Status

www.mozilla.org
General
P3
normal
RESOLVED DUPLICATE of bug 516259
9 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

There doesn't seem to be a good reason for this, and it's sort of annoying/unprofessional.

Comment 1

9 years ago
It's a known issue and I agree that it's annoying.  CC'ing fantasai who had some thoughts about how to fix this.

Updated

9 years ago
Duplicate of this bug: 519052

Comment 3

9 years ago
This problem is also seen on a PC with Windows XP.  Platform and operating system changed to "All".  

This is actually two problems, either of which may also afflict other Mozilla.org pages.  

The cited home page contains two or more elements that have fixed widths.  The combination of these elements yields an overall page with a minimum width greater than the viewing area of the browser window.  This means the page cannot adapt to various monitor sizes, screen resolutions, and browser window widths, a major violation of Web page design recommendations.  

Gecko browsers generally provide a horizontal scroll bar when a page is wider than the browser's viewing area.  Explicit action in the HTML/XHTML, CSS, or scripts for a page is required to suppress a scroll bar.  It appears as if such action was implemented for this page.  This, too, is contrary to Web page design recommendations.  (If the conclusion is invalid -- if nothing was done to suppress the horizontal scroll bar -- then a separate Bugzilla report against Gecko is indicated.)  

I have my screen resolution set to 800x600.  I'm quite sure that I'm not the only Web surfer with 800x600 resolution by choice.  In any case, a Web page that requires horizontal scrolling is poorly designed.  

Yes, I can use navigation arrows on my keyboard to scroll horizontally. 
However, the lack of a scroll bar implies there is no need to scroll.  

Yes, I could set my resolution as high as 1280x1024, but I use 800x600 because my eyes are getting old.  While I could set default font sizes larger, this will not work for all applications on my PC.  Because of this use of screen resolution, there might even be a problem with the ADA (Americans with Disabilities Act) if the site cannot accommodate 800x600.  (In 2008, Target Stores settled an ADA lawsuit over its Web site for $6,000,000 plus unspecified costs for ongoing testing of its pages for accessibility.)
OS: Mac OS X → All
Hardware: x86 → All

Comment 4

9 years ago
This is definitely something we want to fix and any patches to the existing CSS are welcome.  FWIW, I don't believe any content is ever hidden off page -- only part of the right margin.

Updated

9 years ago
Priority: -- → P3

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516259
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.