executable permissions for data files (port bug 461322 to SeaMonkey)

RESOLVED FIXED in seamonkey2.6

Status

SeaMonkey
Build Config
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Robert Kaiser, Assigned: ewong)

Tracking

Trunk
seamonkey2.6
x86
Linux

SeaMonkey Tracking Flags

(seamonkey2.2-, seamonkey2.3- affected, seamonkey2.4-, seamonkey2.6 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
We're shipping a few files installed by suite/app/Makefile with executable permissions when they shouldn't have those. We need to port bug 461322 over to our Makefile.in
(Reporter)

Comment 1

8 years ago
Serge, you are probably the expert on those ports right now, have we done that already?
Fwiw, today saw 
http://hg.mozilla.org/mozilla-central/rev/70ba4f81236f
(no bug) Unset executable flag on a few .cpp & .h files in /xpcom/tests.

***

(In reply to comment #1)

I don't think this was checked yet.
I can't do it myself with something like "ls -l | grep x" as I'm on Windows only.
I don't know if there would be a way to ask mercurial (repository)?
Blocks: 361423
Depends on: 461322
status-seamonkey2.1: --- → ?

Comment 3

7 years ago
MozillaBuild comes with a bash shell you know?

Philip@HARUHI /c/t1/hg/comm-central/suite
$ find . -type f -perm /111 -print
./confvars.sh

Updated

7 years ago
Duplicate of this bug: 361423
I would be happy to take a fix for this for 2.1, but I would not feel comfortable blocking on it.
No longer blocks: 361423
status-seamonkey2.1: ? → wanted

Comment 6

7 years ago
Missed 2.2 would take for 2.3/2.4
status-seamonkey2.1: wanted → ---
tracking-seamonkey2.2: --- → -
tracking-seamonkey2.3: --- → ?
tracking-seamonkey2.4: --- → +
(In reply to comment #3)

> MozillaBuild comes with a bash shell you know?

Sure, but I was/am unsure about what result that would give, or whether/how hg would notice the permission changes (to create a changeset).
(Windows vs Linux cases...)

> Philip@HARUHI /c/t1/hg/comm-central/suite
> $ find . -type f -perm /111 -print
> ./confvars.sh

Confirmed, source tree:
{
... .../comm-central/suite

$ find . -type f -name "*.sh" -print
./confvars.sh
./makefiles.sh

$ find . -type f -perm /111 -print
./confvars.sh
}
I don't know which one should (not) have the permission.


From an (older) 2.4 build, ZIP file:
{
... .../seamonkey24
$ find . -type f -perm /111 -print
./AccessibleMarshal.dll
./components/suite.dll
./crashreporter.exe
./dbghelp.dll
./freebl3.dll
./MapiProxy.dll
./mozalloc.dll
./mozcpp19.dll
./mozcrt19.dll
./mozjs.dll
./mozMapi32.dll
./mozsqlite3.dll
./nsldap32v60.dll
./nsldappr32v60.dll
./nsldif32v60.dll
./nspr4.dll
./nss3.dll
./nssckbi.dll
./nssdbm3.dll
./nssutil3.dll
./plc4.dll
./plds4.dll
./plugin-container.exe
./seamonkey.exe
./smime3.dll
./softokn3.dll
./ssl3.dll
./uninstall/helper.exe
./updater.exe
./xpcom.dll
./xul.dll
}
which is similar to what an older FF6 reports too.
I assume .exe has to be executable, I'm not sure about .dll.


From an Installer file:
To be checked too!?


At least, no "data" file (anymore?) as in bug 461322 :-)
Yet, it looks like /suite/app/Makefile.in could still need to have bug 461322 ported...
If this is fixed soon, I would take it for 2.3, also is quite easy.

I don't mind shipping with it though
status-seamonkey2.3: --- → affected
tracking-seamonkey2.3: ? → -
Whiteboard: [good first bug]
(Assignee)

Updated

7 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 9

7 years ago
Created attachment 552023 [details] [diff] [review]
disabled executable permissions for data files (v1)
Attachment #552023 - Flags: review?(bugspam.Callek)
Comment on attachment 552023 [details] [diff] [review]
disabled executable permissions for data files (v1)

># HG changeset patch
># Parent 70f82b97c52c1c23ed94f85e3a0fb02bc9f0337e
># User Edmund Wong <ewong@pw-wspx.org>
>Bug 513900 - executable permissions for data files (port bug #461322 to SeaMonkey)
>
>diff --git a/suite/app/Makefile.in b/suite/app/Makefile.in
>--- a/suite/app/Makefile.in
>+++ b/suite/app/Makefile.in
> libs::
> 	cp $(MOZILLA_SRCDIR)/testing/xpcshell/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/xpcshell-core.ini
>-	$(INSTALL) $(topsrcdir)/suite/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell
>+	$(INSTALL) $(IFLAGS1) $(topsrcdir)/suite/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell
> 	cp $(topsrcdir)/suite/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/all-test-dirs.list

Lets not change this line, it is never shipped, and I don't want to break this piece of code somehow.

Other than that r+

(Sorry it took so long, I decided I would rather get this patch in, and then address anything we missed in a followup than let this languish further)
Attachment #552023 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 11

7 years ago
Created attachment 558208 [details] [diff] [review]
disabled executable permissions for data files (v2) [Checkin: comment 12]
Attachment #552023 - Attachment is obsolete: true
Attachment #558208 - Flags: review+

Updated

7 years ago
Keywords: checkin-needed
Comment on attachment 558208 [details] [diff] [review]
disabled executable permissions for data files (v2) [Checkin: comment 12]

http://hg.mozilla.org/comm-central/rev/618b5c2caf6c
Attachment #558208 - Attachment description: disabled executable permissions for data files (v2) → disabled executable permissions for data files (v2) [Checkin: comment 12]
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [good first bug]

Updated

6 years ago
status-seamonkey2.6: --- → fixed
tracking-seamonkey2.4: + → -
Target Milestone: --- → seamonkey2.6
You need to log in before you can comment on or make changes to this bug.