vcard 3.0 telephone numbers are not recognized

RESOLVED DUPLICATE of bug 29106

Status

RESOLVED DUPLICATE of bug 29106
9 years ago
6 years ago

People

(Reporter: piessens, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [GS], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009061208 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4pre) Gecko/20090903 Lightning/1.0pre Shredder/3.0b4pre

in 2.1 vcards the telehponenumbers are given as TEL;WORK;VOICE;09979
in 3.0 TEL;TYPE="work,voice" 
The telephonenumbers are not imported when a 3.0 vcard is attached to an email.

Reproducible: Always

Steps to Reproduce:
1.take a mail with 3.0 vcard, 
2.click on the card

Actual Results:  
no telephonenumbers available
(Reporter)

Comment 1

9 years ago
Created attachment 398339 [details] [diff] [review]
patch that fixes this problem 

the original nsVCard.cpp file mentions that part of the file is a copy of a vcc.c file generated by a vcc.y yacc file which got lost. I have written a nsVCard.y yacc file based on the libical-0.43 vcc.y file and the original nsVCard.cpp file.
by running bison -o nsVCard.cpp nsVCard.y a correct cpp file is generated.
The patch itself is a rather ugly approach, if the property is a telephonenumber, the attributes are parsed and stored as in the 2.1 vcard format.
(In reply to comment #1)
> Created an attachment (id=398339) [details]
> patch that fixes this problem 
> 

Thanks for the patch - marking new based on that. If you want your patch to get into thunderbird, you need to request a review as described at https://developer.mozilla.org/de/Getting_your_patch_in_the_tree.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #398339 - Flags: review?(bugzilla)
Your patch looks weird so I guess it might end up being - but still asking for a review can't hurt.
Comment on attachment 398339 [details] [diff] [review]
patch that fixes this problem 

I'm sorry for the big delay in getting back to looking at this.

Unfortunately there are many differences between the bison generated nsVCard.cpp and the existing version.

From a brief look through, it also looks like if we went back to auto-generating, we'd actually loose some of the function calls (e.g. PR_*/PL_*) that we should be using for other system versions.

Therefore I think it is probably best we just continue with the version in the source code for now.

Would you mind regenerating a patch against nsVCard.cpp for just your changes?
Attachment #398339 - Flags: review?(bugzilla) → review-

Updated

7 years ago
Whiteboard: [GS]
Version: unspecified → Trunk

Comment 5

7 years ago
Workaround mentioned by Xenos on GSFN: use MoreFunctionsForAddressBook ( https://nic-nac-project.org/~kaosmos/morecols-en.html ).

> The extension can export in vCard 2.1 and vCard 3.0 (default) format; 
> can import both vCard 2.1 format and vCard 3.0 format.

Comment 6

6 years ago
Note that this bug is especially true for vCards sent by iPhones, which is not that rare these days.
Component: Address Book → Address Book
Product: Thunderbird → MailNews Core

Updated

6 years ago
Blocks: 782609

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 29106
You need to log in before you can comment on or make changes to this bug.