Static character menu item will disapear if charset menu is changed many times

VERIFIED DUPLICATE of bug 49102

Status

()

P3
normal
VERIFIED DUPLICATE of bug 49102
19 years ago
19 years ago

People

(Reporter: teruko, Assigned: cata)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Static character menu item will disapear if you change character coding menu 
many times.

1. Launch Netscape
2. Go to http://home.netscape.com/  (if this is default, you do not need to do 
this.)
3. Select menu View|Character coding -> Multibyte->Japanese (Shift_JIS)
4. Select menu View|Character coding -> Multibyte->Japanese (EUC-JP)
5. Select menu View|Character coding -> Multibyte->Japanese (ISO-2022-JP)
6. Select menu View|Character coding -> Multibyte->Chinese Traditional (Big5)
7. Select menu View|Character coding -> Multibyte->Chinese Traditional (EUC-TW)
   
At this time, if you look at the cached charset menu under View|Character 
coding, looks like this.

Western (ISO-8859-1)
Chinese Traditional (EUC-TW)
Chinese Traditional (Big5)
Japanese (ISO-2022-JP)
Japanese (EUC-JP)
Japanese (Shift_JIS)

8. Exit Netscape and re-launch it
7. Select menu View|Character coding->Multibyte->Korean (EUC-KR)

Look at the cached character coding menu under View|Character coding,
it looks following.

Western (ISO-8859-1)
Korean (EUC-KR)
Chinese Traditional (EUC-TW)
Chinese Traditional (Big5)
Japanese (ISO-2022-JP)
Japanese (EUC-JP)

And, look at static character coding menu View|Character coding->Mutibyte.
They are
Chinese simplified (GB2312)
Chinese simplified (GBX)
Chinese simplified (HZ)
Korean (EUC-KR)
Unicode (UTF-8)
Unicode (UTF-7)

So, at this time, Japanese (Shift_JIS) menu is not available neither in static 
menu nore in cache menu.

Tested 2000-09-05-08 Win32, Mac, and Linux build.
(Assignee)

Comment 1

19 years ago
Another manifestation of the EVIL bug #49102.

*** This bug has been marked as a duplicate of 49102 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
This is a dup of bug 49012:Do not change the "more" submenus anymore
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.