Creating new AB card crashes on OK button

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
critical
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: selmer (gone), Assigned: Eric Vaughan)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
9/5 08 M18

Goto AB, click on new card
fill in fields in card
click on OK
crash.

Talkback ID = TB16703553M
(Reporter)

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 1

18 years ago
Upon attempting to reproduce, I unchecked the "send as plain text" checkbox and
survived the OK button.

Updated

17 years ago
QA Contact: lchiang → esther

Comment 2

17 years ago
esther - can you try to reproduce this?
Severity: normal → major
(Reporter)

Comment 3

17 years ago
9/6 08 m18 commercial

Now I can't dup this.

Comment 4

17 years ago
 If we can't reproduce we shouldn't try to fix it for this release, but just in
case it comes up again, here's the stack.  It looks like it might be a xul bug
based on all of the nsBox code in the stack, so I'm reassigning to trudelle.


   PresShell::HandlePostedReflowCallbacks
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3284]
     PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4335]
     PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3348]
     PresShell::AppendReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2507]
     nsFrame::CreateAndPostReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 3512]
     nsContainerFrame::ReflowDirtyChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 316]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 468]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::MarkDirtyChildren
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 292]
     nsXULTreeOuterGroupFrame::ReflowFinished
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp,
line 1029]
     PresShell::HandlePostedReflowCallbacks
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3284]
     PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4335]
     PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3348]
     PresShell::AppendReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2507]
     nsFrame::CreateAndPostReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 3512]
     nsContainerFrame::ReflowDirtyChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 316]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 468]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::MarkDirtyChildren
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 292]
     nsXULTreeOuterGroupFrame::ReflowFinished
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp,
line 1029]
     PresShell::HandlePostedReflowCallbacks
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3284]
     PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4335]
     PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3348]
     PresShell::AppendReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2507]
     nsFrame::CreateAndPostReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 3512]
     nsContainerFrame::ReflowDirtyChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 316]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 468]
     nsBox::RelayoutDirtyChild
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 457]
     nsBox::MarkDirtyChildren
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 292]
     nsBoxFrame::InsertFrames
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1117]
     FrameManager::InsertFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 696]
     nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8823]
     nsCSSFrameConstructor::RecreateFramesForContent
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11068]
     nsCSSFrameConstructor::AttributeChanged
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 10022]
     StyleSetImpl::AttributeChanged
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 1195]
     PresShell::AttributeChanged
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3421]
     nsXULDocument::AttributeChanged
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1654]
     nsXULElement::SetAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2770]
     nsXULElement::SetAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 1233]
     ElementSetAttribute
[d:\builds\seamonkey\mozilla\dom\src\coreDOM\nsJSElement.cpp, line 240]
     js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 720]
     js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2521]
     js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 736]
     js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
     JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3149]
     nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 862]
<../images/spacer.gif>
Assignee: putterman → trudelle

Comment 5

17 years ago
Why did I get this?  I'm pretty sure we have OK buttons working fine elsewhere
in the product ;-)
Seriously though, do you have some reason for suspecting any of the toolkit
code, even though it is not at the top of the stack?  You'll find box code all
over nearly every stack, but that isn't sufficient reason to pass it off to
EVaughan.
BTW, I can't reproduce this either, using today's verification build on Win98.

Comment 6

17 years ago
Because the AB card is a pretty complicated dialog which means it may behave 
differently than simpler dialogs, there's no mailnews code on the stack, the 
only thing I have to go on is the stack which only shows layout and xptoolkit 
code, and there appears to be a whole lot of recursive calls in nsBox which 
makes it look like a possible candidate to someone who doesn't know the code at 
all.

Besides that, I figured you needed more bugs :-)

Comment 7

17 years ago
Well, thanks for thinking of us!  ->evaughan for a glance at the stack, cc jrgm
to see if he can repro.  Do we know what fields were filled in when it crashed?
 Were the other tab panels involved?  Do we have any other talkback incidents?
severity -> critical due to crash.
Assignee: trudelle → evaughan
Severity: major → critical
Target Milestone: --- → M18

Comment 8

17 years ago
Well, I can't reproduce this. Or rather, I can get a crash in such a specific
way, with a different stack entirely, that were (likely) no longer talking 
about the same bug. So I filed http://bugscape.netscape.com/show_bug.cgi?id=2268

For reference, the specific steps are 1) bring up AB, 2) log in to AIM in the 
sidebar, 3) for a collected address, give it a nickname, and add it to 2+ 
groups, 4) go to the address panel (second one) and enter some address info, 
5) click OK ... crash (reproduced 3 times). 

Just out of curiosity, selmer ... were you logged into AIM and were you adding
a screen name.

Comment 9

17 years ago
Can't reproduce per steps at top of this bug. Marking Worksforme. Please
reopen if this can be reproduced.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

17 years ago
I would have had AIM open because I auto-login.  I was not attempting any
nickname stuff at all.  I entered only first name, last name, and email.

As I said above, I couldn't dup this recently either.

Comment 11

17 years ago
QA-assigned to Suresh per Esther
QA Contact: esther → suresh
(Reporter)

Comment 12

17 years ago
9/26 09 MN6

This is happening to me again.  Talkback ID = TB18095857G
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 13

17 years ago
Once again, unchecking the HTML checkbox allows me to avoid the crash.

Comment 14

17 years ago
Hmm, can't reproduce it here.

On another note, TB 18095857, while it has no function/filename information,
shows the top three frames of the stack as 'addrbook.dll', which would make
this an entirely different crash than the one noted in the stack trace that
begins this bug report. 

Steve: do you want to file a separate bug, or do you just want to assign
this over to whomever handles the addrbook.dll.

Comment 15

17 years ago
Marking Worksforme for the originally reported crash (in nsPresShell). THe
stack trace for the reopened crash is pointing into addrbook.dll. selmer,
I suggest filing a separate bug for the new crash (jrgm using trudelle's account).
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
A bug has been filed for a similar crash in AB. 
http://bugzilla.mozilla.org/show_bug.cgi?id=55071

Updated

17 years ago
QA Contact: suresh → pmock
I'm not crashing on build 2001021404 (NT 4.0) build 2001021408 on Mac, and Linux
2001021408, marking VERIFIED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.