Closed Bug 514582 Opened 13 years ago Closed 13 years ago

ES5 strict mode: defining functions named 'eval' or 'arguments' forbidden

Categories

(Core :: JavaScript Engine, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 514575

People

(Reporter: jimb, Unassigned)

References

(Blocks 1 open bug)

Details

From ES5 Annex C:

It is a SyntaxError to use within strict mode code the identifiers eval or arguments as the Identifier of a FunctionDeclaration or FunctionExpression or as a formal parameter name (13.1). Attempting to dynamically define such a strict mode function using the Function constructor (15.3.2) will throw a SyntaxError exception.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514575
You need to log in before you can comment on or make changes to this bug.