Closed Bug 514794 Opened 10 years ago Closed 10 years ago

mailto: links do not open relative to the parent tab

Categories

(Firefox :: Tabbed Browser, defect, minor)

x86
Windows Vista
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 514310

People

(Reporter: u88484, Unassigned)

References

Details

mailto: links do not open relative to the parent tab.

STR:
1) Open gmail in a tab
2) Open google.com in a new tab
3) Switch to the gmail tab and open a bugzilla related email
4) ctrl+click the bug number near the top of the email to open the bug report (opens next to the gmail tab)
5) ctrl+click the email address in the email

Actual results: new tab to compose email opens next to the google tab

Expected results: new tab to compose email opens next to gmail tab
Flags: wanted-firefox3.6?
Mmm, this is a byproduct of the referrer case, we probably need a better mechanism for this.
Severity: normal → minor
I'm not clear what this bug is about. When I have the two tabs open and I use ctrl+click to open the appropriate bug a new tabs gets added to the end of the list of open tabs. It will not open next to the gmail tab as the reporter stated. Further for step 5 the compose email page opens as a popup window.

Kurt, have you tweaked some of your preferences?
(In reply to comment #2)
> I'm not clear what this bug is about. When I have the two tabs open and I use
> ctrl+click to open the appropriate bug a new tabs gets added to the end of the
> list of open tabs. It will not open next to the gmail tab as the reporter
> stated. Further for step 5 the compose email page opens as a popup window.
> 
> Kurt, have you tweaked some of your preferences?

I am using an hourly build with the patch for bug 465673 which, by default now, changes how new tabs are opened.  Today's nightly will include the fix so you will be able to reproduce this behavior using that nightly from here on out.  

Just so you don't have to read the bug report for bug 465673, the patch changes newly opened tabs to open to the right of the parent tab and doesn't open all tabs at the end of the tab bar.  With this bug here, mailto: links always open at the end of the tabbar.
I tried to make a testcase for this this but for some reason the mailto: link gets changed to something like "https://mail.google.com/mail?view=cm&tf=0&ui=1&to=bug514794@bugzilla.com" instead of it being "mailto:bug514794".  I changed the mailto: setting in the options menu->application tab to always ask but it isn't working.

So the only way to reproduce this without an issue like this is to do it from within gmail as the email links are still mailto: links
This is fixed by the patch in bug 514310.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514310
You need to log in before you can comment on or make changes to this bug.