Closed Bug 515075 Opened 11 years ago Closed 11 years ago

Useablity: Minimize the use of popup error dialogs.

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 123440

People

(Reporter: craighewetson, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13
Build Identifier: version 2.0.0.23 (20090817)

When user doesn't explicitly performs an action, showing an popup error message that he has to close can be annoying. There is an use case to explain what I mean:

Reproducible: Always

Steps to Reproduce:
1. Bongani uses a company laptop and uses thunderbird to send/receive mail through an internal mail server at work.
2. Bongani goes home and works on his laptop.
3. He searches for something in his mail (or wants to look at his schedule for tomorrow).
Actual Results:  
Since he isn't connected to his company's mail server, he gets an annoying error dialog: "Failed to connect to server xXx" and all he did was open thunderbird up.

Expected Results:  
Since he never actually asked thunderbird to do anything, he would had preferred thunderbird to clearly show/indicate that he is not online/connected to his mail server, without him having to confirm the error to thunderbird. 

A simple popup notification would have been suffice to inform Bongani that his mail client could not connect to the mail server. Also to avoid Bongani from missing this error condition/state a graphic/icon could be persisted (until the connection is restored) maybe in the bottom left hand corner. 
Infact the icon that tells the user that he is currently online (bottom rigt hand corner) could be changed to tell him that he isn't connected to his mail server.
 

If there are multiple mail servers that the user connects to (work server and gmail account) then maybe this error could be shown next to each account for which he no longer has connection too.
Duplicate of bug 123440 and others.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.