Closed Bug 515166 Opened 10 years ago Closed 9 years ago

Support scroll indicators in XUL richlistboxes and scrollboxes

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(fennec1.1+)

VERIFIED FIXED
Tracking Status
fennec 1.1+ ---

People

(Reporter: mfinkle, Assigned: vingtetun)

References

Details

Attachments

(1 file, 7 obsolete files)

Attached patch WIP 1 (obsolete) — Splinter Review
We plan on supporting scroll indicators for the web content area, but supporting richlistboxes and scrollboxes will likely be a different implementation.

Here is a simple patch that adds scrollbars as indicators. The patch styles scrollbars to look like indicators and sets the overflow for scrollable areas to "scroll". It has a problem when the window is resized. The overflow seems to go back to "auto".

It's a start.
tracking-fennec: --- → ?
i think scroll indicators in content are much more important than in chrome, a nice to have..
tracking-fennec: ? → 1.0-
Flags: wanted-fennec1.0+
Blocks: 534283
Attached patch Patch (obsolete) — Splinter Review
It can needed some tweaks on the style of the scrollbar thumb
Attachment #399203 - Attachment is obsolete: true
Attachment #420338 - Flags: review?(mark.finkle)
Attached patch patch (obsolete) — Splinter Review
Improvements on Vivien's patch :
- support for horizontal scrollbars
- blueish theme using the same colors as the content scroll indicator patch in bug 461843
Attachment #420338 - Attachment is obsolete: true
Attachment #420338 - Flags: review?(mark.finkle)
Attached image screenshot (obsolete) —
Attachment #420529 - Flags: ui-review?(madhava)
Attachment #420529 - Flags: review?(mark.finkle)
Attached patch new color scheme (grey) (obsolete) — Splinter Review
The color scheme is now grey, with a 4px margin to match the content panning indicators.
Assignee: nobody → fabrice.desre
Attachment #420529 - Attachment is obsolete: true
Attachment #421243 - Flags: ui-review?(madhava)
Attachment #421243 - Flags: review?(mark.finkle)
Attachment #420529 - Flags: ui-review?(madhava)
Attachment #420529 - Flags: review?(mark.finkle)
Attached image screenshot with grey indicators (obsolete) —
Attachment #420530 - Attachment is obsolete: true
As a side note for the in-litmus? flag, I'd like to add this feature to our tests as an update to the existing screen navigation tests rather than their own separate tests.
Flags: in-litmus?
tracking-fennec: 1.0- → 1.1+
this work is in bug 461843 now
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461843
Attachment #421243 - Attachment is obsolete: true
Attachment #421243 - Flags: ui-review?(madhava)
Attachment #421243 - Flags: review?(mark.finkle)
dupe, v.
Status: RESOLVED → VERIFIED
Since bug 461843 has been finally dedicated only to content scrollbars I think this bug could be reopened, and for this occasion I also have a patch :)
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Assignee: fabrice.desre → 21
Attached patch Patch (obsolete) — Splinter Review
The patch use the allowScrollbarsToOverlapContent pref and negative margin to have xul scrollbars floating above content for chrome
Attachment #421244 - Attachment is obsolete: true
Attachment #497956 - Flags: review?(mark.finkle)
Attached patch Patch v0.2Splinter Review
Faster version with the look similar to the one in content.
Attachment #497956 - Attachment is obsolete: true
Attachment #498007 - Flags: review?(mark.finkle)
Attachment #497956 - Flags: review?(mark.finkle)
Comment on attachment 498007 [details] [diff] [review]
Patch v0.2

Works well for me. Let's get some feedback. The negative margin might need to be tweaked later, after we get more feedback.
Attachment #498007 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/e20e308b43e5
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101227 Namoroka/4.0b9pre Fennec/4.0b4pre
Status: RESOLVED → VERIFIED
https://litmus.mozilla.org/show_test.cgi?id=15198
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.