Status

addons.mozilla.org Graveyard
API
--
minor
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: mackers, Assigned: lorchard)

Tracking

unspecified
BW-1.1

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-gb) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 

The extension is designed to stayed logged in forever (unless the user hits "logout"). It does this by storing the authentication token in a user preference.

However, it has been reported that occasionally the token becomes expired and the the API responds with an "unauthorized", causing the extension to log out.

Is this something you can imagine happening and is there a solution? 

Some more details in bug 499276.

This is not a high priority.




Reproducible: Always

Comment 1

9 years ago
(In reply to comment #0)
> This is not a high priority.

Well, maybe it is. Login is not persisting across Firefox sessions at all for me, 100% of the time.
Assignee: nobody → lorchard
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
I can't reproduce this myself, and there is no expiration for auth tokens built into the API.  Do you have any more details about what happens with the API when you see errors?  Some HTTP transcripts or maybe even a token that was once usable and stopped working?

The one case where auth tokens get invalidated is if an attempt to use one is done with a User-Agent that differs from the User-Agent that requested the token originally.  I could try coming up with a patch to disable that, though it's similar to the anti-hijacking security measure also used by the website login.
(Assignee)

Comment 3

9 years ago
Ping: Is this still happening? Do you have any other details?
(Reporter)

Comment 4

9 years ago
I've never been able to reproduce this either.

Brian, you've seen this happening?

Comment 5

9 years ago
(In reply to comment #4)
> Brian, you've seen this happening?

I thought I did, but I think it was another bug which has since been fixed. I have not seen it since.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Target Milestone: --- → BW-1.0.5
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.