Closed Bug 515399 Opened 10 years ago Closed 10 years ago

Cannot add attendees to event invitation [Error "input is null" in calendar-event-dialog-attendees.xml]

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: mnyromyr)

References

Details

(Keywords: regression)

Attachments

(1 file)

Lightning 1.0pre (20090909) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090909 Shredder/3.0b4pre

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090909 Calendar/1.0pre

Steps To Reproduce:
1. Start creating a new event
2. Select Invite Attendees...
3. Enter some email addresses and press OK button to save attendees

Expected Result:
The added attendees are listed in the event dialog.

Actual Results:
None of the added attendees is listed in the event dialog.

Error Console shows many occurrences of the following message:

  Error: input is null
  Source File: chrome://calendar/content/calendar-event-dialog-attendees.xml
  Line: 575
*exact* same problem here using latest nightly build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090914 Lightning/1.0pre Shredder/3.0b4pre

Lightning build 20090913050226

Same error message. Bug confirmed!
Flags: blocking-calendar1.0?
Duplicate of this bug: 516682
I'm seeing this with SeaMonkey trunk on Linux.
OS: Windows 7 → All
Hardware: x86 → All
Guys

is there any workaround ? Invitataion without possibility to invite people does not make sense. What is priority of this bug and when it will be solved ?

Thanks.
I'll try to debug this tomorrow.
Assignee: nobody → mschroeder
Flags: blocking-calendar1.0? → blocking-calendar1.0+
I was already looking...
The problem is that the attendeeCol* nodes created are anonymous nodes which getElementById (usually) can't see (the first instances are part of <content> which seems to make a difference?!). 
The attached patch fixes this bug for me, I didn't see any obvious problems.
Assignee: mschroeder → mnyromyr
Status: NEW → ASSIGNED
Comment on attachment 401115 [details] [diff] [review]
attendees are anonymous

review follows in the morning! ;)
Attachment #401115 - Flags: review?(mschroeder)
Keywords: regression
Comment on attachment 401115 [details] [diff] [review]
attendees are anonymous

Works as expected! r=mschroeder
Attachment #401115 - Flags: review?(mschroeder) → review+
I can not confirm it, I just upgraded to "Lightning: The 17-Sep-2009 04:17 PST" and issues is still there
(In reply to comment #10)
> I can not confirm it, I just upgraded to "Lightning: The 17-Sep-2009 04:17 PST"
> and issues is still there

The patch has not been checked in the code repository yet, so you could not see any changes.
Pushed as <http://hg.mozilla.org/comm-central/rev/06b0427f165c>.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
I can confirm that issue is solved, thanx guys, great job !
VERIFIED per comment#13.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
See Also: → 1447830
You need to log in before you can comment on or make changes to this bug.