Ctrl+U not implemented in Navigator

VERIFIED FIXED

Status

()

Core
Keyboard: Navigation
P2
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jglick, Assigned: Chris McAfee)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+], URL)

(Reporter)

Description

18 years ago
Keyboard accelerators, Ctrl+I and Ctrl+U, are being used for different purposes 
in different apps.

1. Ctrl+I for "Page Info" - doesn't look like any SeaMonkey apps are currently 
doing this (was used in 4.x though and why it got in the spec). Removed from 
Accelerator spec.  (http://gooey/client/5.0/specs/mail/Misc/Accelerators.html)

2. Remove Ctrl+U for "Page Source" - Seamonkey Mail needs to remove this from 
the View Menu.  No Accelerator key for "View Page Source".  Ctrl+U is for 
Underline only.

3. Should Ctrl+I be used for Italics and IM or should we try and find a 
different accelerator for "New IM"?  All the "Ctrl+<letter>" ones are taken.  

Also, Ctrl+B is currently used for Bold (Composer, Mail Compose, IM) and Manage 
bookmarks (in browser).  But, Ctrl+B is not an accelerator that launches an 
Application.  Having an accelerator that launches an App and is used for 
something else is not good. 

"Ctrl+Shift+I" is available.
(Reporter)

Comment 1

18 years ago
How about Ctrl+E?  

It was used for "Center Align" in 4.x Composer/Mail, but is out for Seamonkey 
(Out per cmanske, bug 49245).

Unless anyone has any objections, lets use Ctrl+E for new Instant Message.

So, things that need to be done for this bug:

1. Change "New Instant Message" from "Ctrl+I" to "Ctrl+E" Message.

2. Remove Ctrl+U for "Page Source" - Seamonkey Mail needs to remove this from 
the View Menu.  No Accelerator key for "View Page Source".  Ctrl+U is for 
Underline only.

Who should this bug be assigned to?

Nominate as nsbeta3 because we are using the same accelerator for two 
conflicting functions.
Keywords: nsbeta3

Comment 2

18 years ago
How about Ctrl+Shift+M for IM? The mnemonic is that they both bring up 
"Message" modules. We use similar logic in composer: We let "Ctrl+N" always 
bring up a new Navigator and "Ctrl+shift+N" for a new Composer window.
You are right, of course, that the only time there is a problem is when one
of the keys is an "app launcher" that should be the same in all modules.
Thus Ctrl+B is not a problem comparing, for example, Composers and Bookmarks.
I wish Ctrl+E would be used for "Edit this page" when you are in a browser!
(Or reserved for that possibility in the future?)
But I wouldn't object if you think it's better to use for IM. 
IMHO, it's not a very good mnemonic.
Personaly, I like too ctrl+shift+M for Instant Message. Much better than Ctrl+E

Comment 4

18 years ago
I'l like to hold off on the final descision for this untill I talk to IM folks 
in particular and browser in general Since every one needs to be OK with this as 
it will be in all the apps and IM folks may have an opinion on how to the user 
accesses their stuff.

Comment 5

18 years ago
Ben Chuang and I both agree that Alt+I is much better option for this.
I don't think anthing else uses this option.
Three keys is too much for this operation.

Comment 6

18 years ago
Er...my last comment was regarding invoking Im Compose sessions.

Comment 7

18 years ago
Are you sure? I understood that these are reserved; (the Alt+keyboard letters) 
for web pages. Web page designers will be able to define the Alt keys to do what 
they want. How will we resolve this conflict if you choose Alt? That was one of 
the reasons we have steared clear of Alt this version.

Am I wrong?

Comment 8

18 years ago
I only looked at specs for accelerator keys in NS 6 at 
http://gooey/client/5.0/specs/mail/Misc/Accelerators.html when I made the last  
comment. 
i dont particularly have an opinion on this. UE shd come up with a consistent
definiton of how we do this across the app. 

Comment 10

18 years ago
Lakespur is correct, you can't use "Alt" key in Windows -- it is reserved for
keyboard access to menus. For example, Alt+I in Composer opens the "Insert" 
menu.
(Reporter)

Comment 11

18 years ago
So Ctrl+Shift+M or Ctrl+E are our best suggestions. Either is fine with me. Does 
the AIM team have a preference? If not, lets go with cmanske's and ducarroz's 
suggestion of Ctrl+Shift+M. 

nbaca, scalkins, should we break this into 2 bugs? One for Ctrl+U to be removed 
from Mail and the other for AIM keyboard accelerator to changed? Or can this 
stay in the same bug? Who should this be assigned to? 

Comment 12

18 years ago
We should either rename this bug to just one shortcut and create a new one, or 
mark this as meta and create one bug for each conflict.

Comment 13

18 years ago
Broke Aim accelerator bug out into Bugscape bug 
http://Bugscape.netscape.com/show_bug.cgi?id=2263
(Reporter)

Comment 14

18 years ago
Thank you scalkins. This bug is now just for Ctrl+U (changed summary):

1. Ctrl+U is being used for both "View Page Source" in 3 pane Mail and 
"Underline" in Mail Compose, Composer and IM. Not a huge problem (similar to 
Ctrl+B for "Bold" and "Manage Bookmarks"). 

2. Ctrl+U works for "View Page Source" in Mail, but not in Navigator. Navigator 
has the menu item "View Page Source", just like Mail does, but no visible 
accelerator key (and doesn't work either).  Either Ctrl+U should be removed from 
Mail, or added to Navigator. 

Who gets this bug?
Summary: Ctrl+I and Ctrl+U being used for different purposes in different apps → Ctrl+U implemented in Mail but not Navigator

Comment 15

18 years ago
Is View Source used that often? Escpecially in mail? I'd say it doesn't need
a keybinding. If now one missed it in Navigator, I doubt anyone would miss it
in Mail!

Comment 16

18 years ago
With the scarcity of options fro things that are often used or will be often
used I think at this time that View Page Source is not used enough of critical
enough to warant a Ctrl+ Key binding.
I vote remove.
(Reporter)

Comment 17

18 years ago
Reassigning bug to selmer. Steve, what would you like to do with this one?
Assignee: don → selmer

Comment 18

18 years ago
I don't see the 4xp keyword on this bug.  Is this a 4xp issue now that we're
down to just ctrl+U?

I think we should do whatever 4.x did.  If they didn't implement this binding
anywhere then I'm OK with removing it from Mail.  If it worked in both Nav and
Mail, then it's a Nav bug and I wouldn't recommend removing it from Mail.

Can someone put the 4.x behavior in the bug?
Whiteboard: [b3 need info]
(Reporter)

Comment 19

18 years ago
4.x behavior: Navigator, View Menu:
 - Page Info    Ctrl+I
 - Page Source  Ctrl+U

4.x behavior: 3 Pane Mail, View Menu:
- Page Info  (no accelerator visible and doesn't work)
- Page Source (no accelerator visible but DOES work)

4.x behavior: Standalone Message window (double click on message to open)
- Page Info  (no accelerator visible and doesn't work)
- Page Source - Ctrl+U (and works)

Seamonkey behavior: Navigator View menu
- Page Info (no accelerator visible but Ctrl+I opens an Instant Message - see 
branched Bugscape bug)
- Page Source (no accelerator visible and doesn't work)

Seamonkey behavior, 3 pane Mail/Standalone mail, View menu
No "Page Info" menu item  (and Ctrl+I opens IM)
Page Source - Ctrl+U (and works)

We have a consistency problem here.  Ctrl+U needs to either work both in Mail 
AND Navigator, or not in either.  

Comment 20

18 years ago
It's kinda late to be removing features for this reason.  I doubt you could put
your UE1 keyword on this and mean it. If we were talking about ctrl+P I might
feel otherwise, but we're not.

I'm sending this bug to the browser team so they can plus it or at least
remember to implement the feature.

Changing summary to remove Mail since it works there.
Assignee: selmer → don
Summary: Ctrl+U implemented in Mail but not Navigator → Ctrl+U not implemented in Navigator
Whiteboard: [b3 need info]

Comment 21

18 years ago
nav triage team:
nsbeta3+, reassigning to Lake to define precisely what we should do and not do.
 Then Lake can reassign to Mcafee to implement.
Assignee: don → lake
Priority: P3 → P2
Whiteboard: [nsbeta3+]
(Reporter)

Comment 22

18 years ago
1. Add "Ctrl+U" to the Navigator, View, "Page Source" menu.
2. Implement accelerator Ctrl+U so that it opens Page Source.

Comment 23

18 years ago
Jennifer's got it covered.   Re assigning to McAfee.
Assignee: lake → mcafee
(Assignee)

Comment 24

18 years ago
This is a oneliner addition to bug 51597, navigator accelerator bug.
Marking dup, yes mail part of this works.


*** This bug has been marked as a duplicate of 51597 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
undupping...spoke w/mcafee. i know that this inflates the buglist, but i'd
rather have a separate bug for separate issues, rather than doing the uber-bug
thang --okay, so it's easier for me/qa to track. thx much!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 26

18 years ago
ctrl-u checked in, fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
vrfy fixed 2000.09.15.08/9 on linux, mac and winnt [opt comm].
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.