[WINCE build] msys gives us a "bad file number" error when running nsinstall.exe with Vista UAC on

RESOLVED WONTFIX

Status

()

Core
Build Config
RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
The installer detection on Vista prevents nsinstall.exe from running because it can contains the string "install" in the name. Interestingly, this problem only seems to occur in the WINCE build because if the program is compiled with the "-MD" flag it is not detected as an installer. We normally pass the "-MD" flag through RTL_FLAGS but RTL_FLAGS is only set on WINNT_ and not when OS_ARCH = WINCE. I'm not sure what the best way to fix this is, or if it's even worth fixing.
(Reporter)

Comment 1

9 years ago
The problem can be worked around by disabling UAC.

Comment 2

9 years ago
This should be being prevented by embedding a manifest: http://mxr.mozilla.org/mozilla-central/source/config/rules.mk#1038
It's possible that's not happening on WinCE builds because we probably don't normally use manifests there.
Another workaround is to just start the shell prompt as administrator
Summary: msys gives us a "bad file number" error when running nsinstall.exe with UAC on → [WINCE build] msys gives us a "bad file number" error when running nsinstall.exe with Vista UAC on

Comment 5

8 years ago
(In reply to comment #1)
> The problem can be worked around by disabling UAC.

I'm on a Vista (desktop system) using VS2008Express and Mozbuild 1.4
 and am being hit by this bug.  Can't compile m-c or c-c.  

Right clicking on start-msvc9-shortcut and selecting "Run as Administrator"
makes no difference.  Still get this Bad File Number error.  I look up
the Event Log and see this:

   Activation context generation failed for 
   "s:\moz\m-c\objdir-ff-release\config\nsinstall.exe".Error in 
   manifest or policy file "s:\moz\m-c\objdir-ff-release\config\nsinstall.exe"
   on line 10. Multiple requestedPrivileges elements are not allowed in 
   manifest.

Looking at the manifest, I only see one requestedPrivileges element, so I'm
stumped.
We should embed manifest for host programs even in WINCE builds.

Comment 7

8 years ago
An addendum:  I ended up with this error because I had mixed up my sdks.  
I had them (2003 Platform SDK and Win7 SDK) installed in the same directory.  
Separating them seems to have solved this problem.

But I do agree that embedding the manifest would solve this issue.

RE: Comment #1, will there be a problem if RTL_FLAGS was also applied 
to WINCE?
Duplicate of this bug: 549745

Comment 9

7 years ago
WinCE/Windows Mobile support has been removed from the main build system, Spidermonkey, mobile installer, in-app updater and so on (see bug 614720, bug 554087 and all their dependants). Until such point where MS decide to release a Windows Phone 7 NDK and the decision is made to port to that platform, this is WONTFIX.

Filter bugmail on WinCEMassWONTFIX.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.