Marking message as not spam doesn't clear deleted flag from message

RESOLVED FIXED in Thunderbird 3.0rc1

Status

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: shopik, Assigned: rkent)

Tracking

Trunk
Thunderbird 3.0rc1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
When you have "Mark as deleted" model enabled and some message detected as spam and you mark it as not spam TB doesn't returnt it normal state it still marked as deleted. Same for scam type of messages.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090906 Shredder/3.0b4pre
Is this a regression ?
(Reporter)

Comment 2

9 years ago
2.0.0.23 seems have different behavior it doesn't mark message as deleted, if I mark message as spam and select option "move message to Junk"
(Assignee)

Comment 3

9 years ago
Created attachment 401073 [details] [diff] [review]
Undelete imap unjunk messages
Assignee: nobody → kent
Status: NEW → ASSIGNED
Attachment #401073 - Flags: superreview?(bienvenu)
Attachment #401073 - Flags: review?(bienvenu)
(Assignee)

Updated

9 years ago
Whiteboard: [needs r/sr bienvenu]
(Assignee)

Comment 4

9 years ago
Without undelete, this bug makes unjunk on imap pretty worthless. So I'm requesting blocking - which is easier of course because there is also a patch here!
Flags: blocking-thunderbird3?

Updated

9 years ago
Whiteboard: [needs r/sr bienvenu] → [no l10n impact][needs r/sr bienvenu]

Comment 5

9 years ago
Comment on attachment 401073 [details] [diff] [review]
Undelete imap unjunk messages

doubt we'd block on an imap delete model & junk bug, to be honest :-) But this looks OK, thx for the patch.
Attachment #401073 - Flags: superreview?(bienvenu)
Attachment #401073 - Flags: superreview+
Attachment #401073 - Flags: review?(bienvenu)
Attachment #401073 - Flags: review+
(Assignee)

Comment 6

9 years ago
Comment on attachment 401073 [details] [diff] [review]
Undelete imap unjunk messages

Since bienvenu did not accept blocking, I guess I need a+ at this point.
Attachment #401073 - Flags: approval-thunderbird3?
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][needs r/sr bienvenu] → [no l10n impact][needs a+]
Target Milestone: --- → Thunderbird 3.0rc1
Attachment #401073 - Flags: approval-thunderbird3? → approval-thunderbird3+
(Assignee)

Comment 7

9 years ago
Checked in as http://hg.mozilla.org/comm-central/rev/324e7b178ad7
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][needs a+] → [no l10n impact]
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.