Closed Bug 516115 Opened 11 years ago Closed 11 years ago

hyperlinks translate to incorrect URL - images not displayed - web folders not read properly - all okay before latest release

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: david.cgl, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Web page http://www.hookertactical.com/1Fil/W1_Bullets.htm is now being read as http://www.hookertactical.com/1Fil%5CW1_Bullets.htm when the hyperlink is clicked.
NOTE1: The forward slant before the W1 has been replaced by %5C, making it an incorrect URL.  Because of this problem, the images are not displayed.  Before this release, Firefox displayed the Hooker Tactical web pages correctly (with images).
NOTE2: When the correct URL is entered manually i.e.
http://www.hookertactical.com/1Fil/1W_Bullets.htm the page displays with its images.

Reproducible: Always

Steps to Reproduce:
1. Go to home page http://www.hookertactical.com/default.htm
2. Click on "Bullets/Ammunition" hyperlink button.
3. URL address is http://www.hookertactical/1Fil%5CW_Bullets.htm
4. View page with missing images and incorrect URL.
5. Correct URL to http://www.hookertactical.com/1Fil/1W_Bullets.htm
6. Note that page displays properly with images.

Actual Results:  
1. While viewing home page (http://www.hookertactical.com/default.htm) click "Bullet/Ammunition" hyperlink button.
2.Firefox translates hyperlink (http://www.hookertactical.com/1Fil/1W_Bullets.htm) incorrectly to http://www.hookertactical.com/1Fil%5CW_Bullets.htm
3. The text of the page is displayed but the images are not.

Expected Results:  
1. While viewing home page (http://www.hookertactical.com/default.htm) click "Bullet/Ammunition" hyperlink button.
2.Firefox translates hyperlink (http://www.hookertactical.com/1Fil/1W_Bullets.htm) correctly to http://www.hookertactical.com/1Fil/1W_Bullets.htm
3. The text and images of the page are displayed correctly.

This problem is essentially the same as Bug 516108.
If you know it's a duplicate why waste our time raising it again?

Contact the maintainer of the web site and ask them to fix it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: backslash
You need to log in before you can comment on or make changes to this bug.