Closed Bug 516189 Opened 12 years ago Closed 12 years ago

mochitest-browser-chrome: "browser_bug471962.js | Timed out" (and leaks) since bug 188253 landing

Categories

(SeaMonkey :: Download & File Handling, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0

People

(Reporter: sgautherie, Assigned: iann_bugzilla)

References

(Blocks 1 open bug, )

Details

(Keywords: fixed-seamonkey2.0, regression)

Attachments

(1 file, 1 obsolete file)

Summary: mochitest-browser-chrome: "browser_bug471962.js | Timed out" (and leaks) since Sep 10 16:xx:xx 2009 → mochitest-browser-chrome: "browser_bug471962.js | Timed out" (and leaks) since bug 188253 landing
Hardware: x86 → All
This patch:
* Adds a dummy aSkipPrompt argument to internalSave in ContentAreaUtils.js

The reason why we're having this issue is that the test is trying to send false as a value for cacheKey which is not liked.
This patch makes SM's internalSave API match that of toolkit, so should resolve the issue.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #400311 - Flags: superreview?(neil)
Attachment #400311 - Flags: review?(neil)
Blocks: 484616
Comment on attachment 400311 [details] [diff] [review]
Add dummy aSkipPrompt argument to internalSave patch v0.1

aSkipPrompt doesn't mean what it says. When false, it forces the prompt. When true, it uses the preference. We always want to use the preference, so you should always pass true to aSkipPrompt, for forward compatibility. (Maybe you should also rename it too!)
Attachment #400311 - Flags: superreview?(neil)
Attachment #400311 - Flags: superreview+
Attachment #400311 - Flags: review?(neil)
Attachment #400311 - Flags: review+
Changes since v0.1:
* Pass true rather than false to the dummy param.
* Rename param from aSkipPrompt to aUsePref.

Requesting a= for low risk patch that fixes an issue with automatic tests.
Attachment #400311 - Attachment is obsolete: true
Attachment #400391 - Flags: superreview+
Attachment #400391 - Flags: review+
Attachment #400391 - Flags: approval-seamonkey2.0?
Attachment #400391 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Comment on attachment 400391 [details] [diff] [review]
Add dummy aUsePref argument to internalSave patch v0.1a [Checkin: Comment 4]

http://hg.mozilla.org/comm-central/rev/076c56066ffe
Attachment #400391 - Attachment description: Add dummy aUsePref argument to internalSave patch v0.1a → Add dummy aUsePref argument to internalSave patch v0.1a [Checkin: Comment 4]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: blocking-seamonkey2.0?
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
V.Fixed, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1252963001.1252969103.28261.gz
Linux comm-1.9.1 unit test on 2009/09/14 14:16:41
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.