Create Privacy page for Mobile

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: sgarrity, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Comment hidden (empty)
(Assignee)

Updated

9 years ago
Blocks: 516691
(Assignee)

Updated

9 years ago
Duplicate of this bug: 497189
(Assignee)

Comment 2

9 years ago
This page is setup in trunk in r51503.
Assignee: nobody → steven
(Assignee)

Comment 3

9 years ago
Caitlin - it looks like there were several links titled as an "article in our Firefox Knowledge Base" that were changed to "article in our Firefox for mobile Knowledge Base". I wondered if perhaps this was a case of overzealous search-and-replacing?
Is a link going to be added to https://www.mozilla.com/legal/privacy ?

Linking to that page was my plan for addressing the privacy policy part of bug 514467.
(Assignee)

Comment 5

9 years ago
(In reply to comment #4)
> Is a link going to be added to https://www.mozilla.com/legal/privacy ?

Makes sense to me. Caitlin - should I add that?

Comment 6

9 years ago
Hi Steven, yes I think we should place a link on existing privacy landing page to mobile. Also, here are the links in chrono order for Privacy Policy:

Maemo: (http://maemo.nokia.com/)
Windows Mobile (http://www.microsoft.com/windowsmobile/en-us/default.mspx)
Firefox for computers: "http://www.mozilla.com/en-US/legal/privacy/firefox-en.html"
Mozilla Privacy Policy:"http://www.mozilla.org/about/policies/privacy-policy.html"
Knowledge base: https://mobile.support.mozilla.com
Blocklisted items: "http://www.mozilla.com/blocklist/"
Interactive product features> knowledge base article: "http://support.mozilla.com/kb/Firefox+makes+unrequested+connections" \l "Auto_update_checking"
Blocklist featue> knowledge base article: http://www.support.mozilla.com/kb/Firefox+makes+unrequested+connections" \l "Extensions_blocklist_updating
location-aware feature: http://www.mozilla.com/en-US/firefox/geolocation/
third party service providers: http://locationaware.org/
third party service providers> Security: http://www.mozilla.com/en-US/legal/privacy/firefox-third-party.html
Secure Website certificat> knowledge base: "http://www.support.mozilla.com/kb/OCSP+error+when+accessing+secure+sites
Mozilla Web Site Services terms: link to About Rights
Cookies>knowledge base article:  "http://support.mozilla.com/kb/Cookies"
mailing list: "https://lists.mozilla.org/listinfo/announce"
news group:  "http://groups.google.com/group/mozilla.announce"
email:  "mailto:privacy@mozilla.com"
(Assignee)

Comment 7

9 years ago
I've updated these links (r51598). A few questions.

> Knowledge base: https://mobile.support.mozilla.com
I'm not sure which instance of the text that should link to, or is that the domain for all of the Knowledge Base links in the text?

Also not sure which reference to third-party providers should link to "http://locationaware.org/"

> Mozilla Web Site Services terms: link to About Rights
This is currently linked to http://www.mozilla.com/en-US/legal/eula/, which seems right?

> email:  "mailto:privacy@mozilla.com"
These have been left un-linked in the other policies - would you still like it linked to the email address?
(Assignee)

Comment 8

9 years ago
Also, the link has been added to the main privacy page in r51655: 

https://www-trunk.stage.mozilla.com/en-US/legal/privacy/

Comment 10

9 years ago
The current title to the mobile privacy policy is not quite right. Privacy Policy title should read: Mozilla Firefox for Mobile Devices Privacy Policy

Comment 11

9 years ago
In the add-ons section of Privacy Policy the link should be: https://addons.mozilla.org/en-US/mobile
instead of https://addons.mozilla.org/en-US/firefox/Firefox%20for%20mobile/
(it's currently addons.mozilla.org/fennec)

Comment 12

9 years ago
In Location-Aware section> third party service providers link should be: http://locationaware.org/

Comment 13

9 years ago
Under Security section> third party service providers link should be: http://www.mozilla.com/en-US/legal/privacy/firefox-third-party.html
(Assignee)

Comment 14

9 years ago
(In reply to comment #9)
> 2) After speaking with Catherine, this link is not correct:
> http://www.mozilla.com/en-US/legal/eula/. But rather, "about:rights"
> 3) Lets leave it unlinked.

I'm not sure I follow - should the "Mozilla Web Site Services Terms" text actually link to href="about:rights"? That link won't work for people using older versions of Firefox or other browsers. I'm not sure what should be unlinked?

(In reply to comment #13)
> Under Security section> third party service providers link should be:
> http://www.mozilla.com/en-US/legal/privacy/firefox-third-party.html
What about the link in this line: "Location-aware Service Providers. In addition, our service providers have their own _privacy policy_." Where should "privacy policy" link on that line?

The other changes are all made in r51723.

Comment 15

9 years ago
(In reply to comment #14)
> (In reply to comment #9)
> > 2) After speaking with Catherine, this link is not correct:
> > http://www.mozilla.com/en-US/legal/eula/. But rather, "about:rights"
> > 3) Lets leave it unlinked.


> 
> I'm not sure I follow - should the "Mozilla Web Site Services Terms" text
> actually link to href="about:rights"? That link won't work for people using
> older versions of Firefox or other browsers. I'm not sure what should be
> unlinked?

Legal wants this link to go to About Rights page. 
"Leave it unlinked" was in response to you inquiry about the email address at the bottom.
> 
> (In reply to comment #13)
> > Under Security section> third party service providers link should be:
> > http://www.mozilla.com/en-US/legal/privacy/firefox-third-party.html
> What about the link in this line: "Location-aware Service Providers. In
> addition, our service providers have their own _privacy policy_." Where should
> "privacy policy" link on that line?

I don't see Privacy Policy for location-aware section. This is the copy I got from legal: "Location-aware Feature.  Firefox for mobile offers a Location-Aware Feature [hyperlink to feature’s Learn More], parts of which may be provided by third party service providers [hyperlink to list of providers]."
> 
> The other changes are all made in r51723.
(Assignee)

Comment 16

9 years ago
(In reply to comment #15)
> Legal wants this link to go to About Rights page.

Sorry for all the questions - what's the URL for the About Rights page? I'm not sure exactly which page we're talking about.
Duplicate of this bug: 496943

Comment 18

9 years ago
About:Rights, similar to how it is in Firefox is in-product. It's just "about:rights"
Talked to Steven and Caitlin, they agree this bug is done.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified FIXED on http://www.mozilla.com/en-US/legal/privacy/firefox/mobile/; thanks.
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.