Closed Bug 516699 Opened 10 years ago Closed 10 years ago

Increase the interval between low-memory notifications

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: dougt, Assigned: dougt)

Details

Attachments

(1 file)

When I landed Bug 475595, i left the interval between the time we would rebroadcast a low-memory notification as 100ms.  Vlad suggested that we could increase this value:

>100ms seems really aggressive; I'd make that 1000ms if not more.  If we're out
of memory we may be hitting some sort of swap, so it could well be longer than
100ms just due to swapping or whatever, and we'll end up doing a lot of
flushing here for probably no good reason.

We should investigate using 1s as the value.
Attached patch patch v.1Splinter Review
works fine.
Attachment #400805 - Flags: review?(vladimir)
http://hg.mozilla.org/mozilla-central/rev/eb15507581d6
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Flags: blocking1.9.2?
Attachment #400805 - Flags: approval1.9.2+
could this have caused a Ts regression? it's in the range for bug 517915.
Dietrich, this change was to reduce the amount of work we do in low memory situations - so, i do not think it could be part of the regression.
You need to log in before you can comment on or make changes to this bug.