Closed Bug 517915 Opened 10 years ago Closed 10 years ago

Ts Regression around 9/15 (~12% mac, ~1% linux)

Categories

(Firefox :: General, defect, P1)

x86
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 517549

People

(Reporter: dietrich, Unassigned)

References

()

Details

(Keywords: perf, regression)

see bug URL, ~12% startup regression. haven't looked yet to see about other platforms beside mac.

9/15 - 9/16 checkins:

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=9%2F15%2F09&enddate=9%2F16%2F09
Flags: blocking-firefox3.6?
Summary: Ts Regression around 9/15 → ~12% Ts Regression around 9/15
linux shows a trend upward, about 5ms:

http://graphs.mozilla.org/graph.html#tests=[{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%2251%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%2252%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%2253%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%2254%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%2273%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22188%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22189%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22190%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22191%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22192%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22193%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22194%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22195%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22196%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22197%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22198%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22199%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22200%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22201%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22202%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22203%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22204%22},{%22test%22:%2216%22,%22branch%22:%221%22,%22machine%22:%22205%22}]&sel=1252755977,1253516627
OS: Mac OS X → All
no regression for xp or vista.
Summary: ~12% Ts Regression around 9/15 → Ts Regression around 9/15 (~12% mac, ~1% linux)
txul regression of varying degree across almost all platforms around the same time: http://graphs.mozilla.org/dashboard/. possibly related, given the timeframe.
backtracked on the tinderbox, found the last good run and first bad run for talos-rev2-leopard07. here are the changesets in that window:

Use gcc-4.2 and the 10.5 SDK by default in Gecko 1.9.3. Gecko 1.9.3 builds will no longer run on Mac OS X 10.4. b=501436 r=ted 
http://hg.mozilla.org/mozilla-central/rev/594dd7f280fa

Bug 513924  - "remove tons of options from configure" [r=ted.mielczarek r=benjamin] 
http://hg.mozilla.org/mozilla-central/rev/21e5393f648c

Use gcc-4.2 and the 10.5 SDK by default in Gecko 1.9.3. Gecko 1.9.3 builds will no longer run on Mac OS X 10.4. b=501436 r=ted 
http://hg.mozilla.org/mozilla-central/rev/a4e2df0a6af5

Bug 516699  - Increase the interval between low-memory notifications. r=vlad 
http://hg.mozilla.org/mozilla-central/rev/eb15507581d6

Breakpad PPC bustage fix. r=ted 
http://hg.mozilla.org/mozilla-central/rev/9c3a70ea7acf

Bug 516769  - WINCE IsLowMemory fixups. r=vlad 
http://hg.mozilla.org/mozilla-central/rev/9a19776b0676

tinderbox page: http://tinderbox.mozilla.org/showbuilds.cgi?tree=Firefox&maxdate=1253034909&legend=0&norules=1
This caused a bit of a Ts regression but most of it was likely due to bug 517549, which this caused because it turned on expensive 10.5 TIS calls by accident. That has been fixed and now Ts is much lower than it was before this bug.

This would not have caused a Ts regressions on other platforms, as discussed in the perf regression bug.
Oops, I meant to post comment #6 in bug 501436.
thanks josh -> duping against bug 517549
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517549
Flags: blocking-firefox3.6?
You need to log in before you can comment on or make changes to this bug.