Closed Bug 516820 Opened 12 years ago Closed 12 years ago

turn off tiger tests on moz-central/support per-OS testing in talos buildbot configs

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: anodelman, Assigned: anodelman)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
We no longer support running moz-central on tiger systems.  As such we need to turn off the talos test for a single platform.  This does that by providing each talos test per tree with a set of OSs that it can be run on.
Attachment #400894 - Flags: review?(bhearsum)
After brief irc with ted we are going to ignore try talos for now, it will need a more robust solution since we still want to support being able to test builds that are runnable on tiger - so we can't entirely disable support there.
Attachment #400894 - Flags: review?(bhearsum) → review+
Comment on attachment 400894 [details] [diff] [review]
run talos tests per-os, do not run moz-central on tiger

This seems fine
Duplicate of this bug: 516817
Comment on attachment 400894 [details] [diff] [review]
run talos tests per-os, do not run moz-central on tiger

Turns out this patch had problems:
* ALL_PLATFOMRS != ALL_PLATFORMS
* You can't use the '+' operator on dicts, apparently. You'll need to use .update()

We got tight for time in the downtime this morning so I didn't get a chance to look at fixing it.
Attachment #400894 - Flags: review+ → review-
Attachment #400894 - Attachment is obsolete: true
Attachment #401236 - Flags: review?(bhearsum)
Comment on attachment 401236 [details] [diff] [review]
run talos tests per-os, do not run moz-central on tiger (take 2)

Unfortunately, this doesn't pass checkconfig either. You can't concatenate the lists with a string. You'll have to use ['leopard'] instead. r=me with that change.
Attachment #401236 - Flags: review?(bhearsum) → review+
Comment on attachment 401236 [details] [diff] [review]
run talos tests per-os, do not run moz-central on tiger (take 2)

changeset:   1545:ec36de49b85a
Attachment #401236 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.