"Use stylesheets": add support to use non stylesheets not even inline

RESOLVED DUPLICATE of bug 32372

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED DUPLICATE of bug 32372
18 years ago
16 years ago

People

(Reporter: Tobias Burnus, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Hi this is with 2000-09-06-21/Linux and a strip off from a bug reported in 6782.

Presently it is possible to disable stylesheets which are in external files via
"Use Stylesheet"|"None" (at least until this issue is resolved this menu item
string will probably change, see bug 51688; so you can use "None"). This request
ask for the possibility to disable all (author) stylesheets: those in external
files <link>, those in the header <style> and those in the tags itself style="".

This is related to:
bug: 32372; should be able to enable/disable style sheets via a pref in UI
OS: Linux → All
Hardware: PC → All
*** Bug 51686 has been marked as a duplicate of this bug. ***
This should be a single option that should disable inline styles, persistent
embedded stylesheets, persistent linked stylesheets, and probably also non-CSS
presentational hints.

It would be bad to distinguish persistent linked stylesheets from persistent
embedded stylesheets because the decision to choose between the two should be
made at the convienience of the author.
(Assignee)

Comment 3

18 years ago


*** This bug has been marked as a duplicate of 6782 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified dup of #6782
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
This isn't really a dup of bug 6782. 6782 is *much* wider in scope; this is only 
a small part of it. It's stuff like this that makes me so confused about the 
difference between "duplicate" and "dependency"...

Somehow I don't think this is going to get fixed until someone decides to tackle 
all of 6782--which AFAICT isn't happening anytime soon. What's there to fix?
It's resolved and verified already! But either this or bug 51688 needs to be 
fixed for mozilla 1.0 or we're going to confuse people when the functionality of 
"none" changes.

Updated

16 years ago
Blocks: 107023

Comment 6

16 years ago
Splitting up bug 6782 ("UI for alternate and user stylesheets").

"One bug report == one issue is one of the golden rules of Bugzilla because it
enables independent tracking and prioritization of each issue."
                                              -- ekrock@netscape.com, bug 4510
Status: VERIFIED → REOPENED
Depends on: 32372
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

16 years ago
Marking dup of 32372.  We'll decide later whether or not we want "Use Stylesheet 
| None" to reflect the state of the pref that disables all styles.

Dbaron wrote in bug 51688 comment #2: "There have been many other proposals for 
how to differentiate between turning off all preferred and alternate stylesheets 
and turning off all author styles. See the long discussion on bug 6782."


*** This bug has been marked as a duplicate of 32372 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Changing QA contact
QA Contact: chrisd → madhur
You need to log in before you can comment on or make changes to this bug.