[autoconfiguration] "Download new messages automatically" should be checked/activated/enabled by default (at least for POP3 accounts!)

VERIFIED FIXED in Thunderbird 3


Account Manager
9 years ago
8 years ago


(Reporter: Thomas D. (currently busy elsewhere), Assigned: Bienvenu)


Thunderbird 3
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Thunderbird Tracking Flags

(thunderbird3.0 .1-fixed)


(Whiteboard: [fixed RC2 build 1])


(1 attachment)

Using Quick Mail Account Setup, we should really activate the checkbox for "Download new messages automatically". It's extremely irritated to hear the bell for new messages, see biff saying "125 new messages", but not see a single mail in your "Smart Folders" Inbox yet. (Due to another bug which is about to be posted, TB will actually ignore that "Download ... automatically" is NOT checked and download messages when you click on the account's folder at the bottom of smart folders view.)

I don't know about IMAP, but POP3 users are guarantied to want their mail downloaded to their inbox, otherwise there is no point of using TB.

Current behaviour:
Default Quick Account Setup does NOT have "Download new messages automatically" checked.
(btw, I wonder how this interacts with "delete after 14 days on server")

Expected behaviour:
At least for POP3 accounts, "Download new messages automatically" should be checked by default.


9 years ago
Summary: [autoconfiguration] Download new messages automatically must be checked/activated by default (at least for POP3 accounts!) → [autoconfiguration] "Download new messages automatically" should be checked/activated/enabled by default (at least for POP3 accounts!)


9 years ago
Duplicate of this bug: 502702


9 years ago
Blocks: 506290

Comment 2

8 years ago
This might(!) be an easy workaround for fixing Bug 529364: Thunderbird 3.0.1pre does not automatically get new pop3 mail upon startup ("check for new messages at startup")
Depends on: 529364

Comment 3

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20091121 Thunderbird/3.0

This should block the final release.

Default behaviour for POP3 is currently this
(RC1 build 3, clean install, new profile):

- "Automatically download new messages" is unchecked (OFF) by default (this bug)
- therefore, TB will NEVER download any new messages automatically (neither at startup NOR every [10] minutes!)
- User needs to download all messages manually ("Read messages", "Get Mail")

too bad, we're a mail client and we don't download pop mail messages automatically unless user intervenes to do trigger the action himself

(pls correct me if I'm wrong about the intended or real behaviour)
Severity: normal → major
Flags: blocking-thunderbird3?
Ugh that isn't nice, thanks for filing this Thomas.  This would be really good to have fixed but I'm not sure we can block the TB3.0 release for this.  Might be something we have to sneak into the 3.0.1 release instead.  I'll wait to see what others think as this feels mostly like an engineering choice.

Comment 5

8 years ago
Created attachment 415196 [details] [diff] [review]
proposed fix

This sets download_on_biff to true for new pop3 accounts, by default, but allows the server config to be overridden (though that may be overkill).
Assignee: nobody → bienvenu
Attachment #415196 - Flags: superreview?(bugzilla)
Attachment #415196 - Flags: review?(bwinton)
Comment on attachment 415196 [details] [diff] [review]
proposed fix

Yeah, it's a bit of overkill, but I don't think it's too bad, and it does what it says it does.

Would you please edit https://wiki.mozilla.org/Thunderbird:Autoconfiguration:ConfigFileFormat and mention the new element, and possibly also add a comment to bug 522253 so that Louie can add the element.

Attachment #415196 - Flags: review?(bwinton) → review+

Comment 7

8 years ago
I've updated both the wiki page and that bug.
Attachment #415196 - Flags: superreview?(bugzilla)
Attachment #415196 - Flags: superreview+
Attachment #415196 - Flags: approval-thunderbird3.0.1+
Attachment #415196 - Flags: approval-thunderbird3+
Flags: blocking-thunderbird3? → blocking-thunderbird3+

Comment 8

8 years ago
changeset:   4470:60852ba581e4
tag:         tip
user:        David Bienvenu <bienvenu@nventure.com>
date:        Mon Nov 30 16:38:44 2009 -0800
summary:     fix 516950 autoconfig pop3 accounts should be configured to download new mail, r=bwinton, sr=standard8

fixed on trunk
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
Checked into 1.9.1: http://hg.mozilla.org/releases/comm-1.9.1/rev/93ed7c6dc038
Checked into relbranch: http://hg.mozilla.org/releases/comm-1.9.1/rev/0ee60a0ba075
status-thunderbird3.0: --- → .1-fixed
Whiteboard: [fixed RC2 build 1]
Target Milestone: Thunderbird 3.1a1 → Thunderbird 3

Comment 10

8 years ago
> allows the server config to be overridden (though that may be overkill).

Yes, I intentionally didn't expose such settings to ISPs. We should do what users want, not ISPs. ISPs have an incentive to reduce load on their servers. But Thomas D. was very clear about how users would feel.
I suggest to remove the XML element.

Comment 11

8 years ago
remember that the isp might be an enterprise...and this setting has very little to do with server load (perhaps you're thinking of leave on server). In fact, changing the default actually slightly increases server load over all.
Keywords: verified-thunderbird3.0
You need to log in before you can comment on or make changes to this bug.