Closed Bug 517269 Opened 11 years ago Closed 10 years ago

getCookie is not defined in line 233 when searching in the new Ask a Question form

Categories

(support.mozilla.org :: General, defect, P5, minor)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephend, Assigned: paulc)

References

()

Details

(Whiteboard: sumo_only)

Attachments

(2 files)

Attached image Screenshot
When I load http://support-stage.mozilla.org/tiki-view_forum.php?locale=en-US&forumId=1, type a search term, and click Search, I get:

getCookie is not defined in line 233
This actually isn't specific to the forums, so re-slotting components.
Assignee: james → nobody
Component: Forum → General
QA Contact: forum → general
Assignee: nobody → james
Probably caused by tiki-js.js not being loaded everywhere it's needed. I know I've seen this error on other pages, as well, so I'll keep an eye out.
Target Milestone: 1.4 → 1.4.1
I propose we just remove that annoying getCookie() call. I believe it's only used to fill out the search form with the previous search value -- why is that useful?
Severity: major → minor
Priority: -- → P5
Not useful here, getting rid of getCookie sounds good.
David, maybe we should discuss the usefulness of pre-filling the search box with the last used value. Could you perhaps reiterate why it was set initially, and if we want it on the small search in the sidebar as well?
This was discussed before but I can't find the bug number so let me reiterate my personal opinion here:

I don't see the point of remembering the value of the search box for any pages BUT the search results page. In other words, I would be more than fine with removing it from pages like this.
Attached patch v1Splinter Review
I also searched the DB and luckily found nothing. Hence, this should take care of all the search-related cookies we set. I grepped for: "fsearch", "getCookie", "setCookie" and looked at all instances, so I'm pretty sure I didn't miss any.
Assignee: james → paulc
Attachment #404873 - Flags: review?(james)
Comment on attachment 404873 [details] [diff] [review]
v1

WFM, but I'm keeping my eyes open during QA.
Attachment #404873 - Flags: review?(james) → review+
r52968 (trunk)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I filed bug 520941 while testing this fix; that's not a regression from this patch, at least (already in production).
Sizable change, but we've got a pretty competent BFT to run this release, along with ad-hoc testing (of which I've already done a fair amount).

This specific fix is good, and we'll aim to shake out regressions as we work on 1.4.1.

Verified FIXED.
Status: RESOLVED → VERIFIED
r53558
Previous was for prod. I managed to commit to fennec without conflicts too: r53559
Whiteboard: tiki_bug
Looks like sumo_only or tiki_fixed, can't find occurences in tiki templates.
Whiteboard: tiki_bug → sumo_only
Definitely sumo_only.
You need to log in before you can comment on or make changes to this bug.