Pending crash report resubmission fails if "submitted" directory does not exist

RESOLVED FIXED

Status

()

Toolkit
Crash Reporting
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: wildmyron, Assigned: cjones)

Tracking

unspecified
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(status1.9.2 .4-fixed)

Details

(Whiteboard: [fixed-lorentz])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090917 Namoroka/3.6a2pre (.NET CLR 3.5.30729)

STR:
1. Delete/move folder %APPDATA%\Mozilla\Firefox\Crash Reports\submitted
2. Crash Firefox without network connection to get a pending crash report.
3. Restore network connection, open Firefox and go to about:crashes
4. Click pending crash report id

Expected:
Report is submitted

Actual:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileOutputStream.init]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://global/content/crashes.js :: writeSubmittedReport :: line 117"  data: no

Manually creating folder named "submitted" in "Crash Reports" allows resubmission to succeed.
Good catch, thanks!
Assignee: nobody → ted.mielczarek
Duplicate of this bug: 551482
Blocks: 478976
Created attachment 432866 [details] [diff] [review]
Create the Crash Reporter/submitted/ directory if it doesn't already exist
Assignee: ted.mielczarek → jones.chris.g
Attachment #432866 - Flags: review?(ted.mielczarek)
Blocks: 544936
Duplicate of this bug: 553148
Comment on attachment 432866 [details] [diff] [review]
Create the Crash Reporter/submitted/ directory if it doesn't already exist

Should have fixed this a while ago, thanks! This could also really use a test. We could probably test it easily by just changing the existing test that submits from about:crashes to not put anything in the submitted dir (or create the dir).

Removing the add_fake_crashes call here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/test/browser/browser_aboutCrashesResubmit.js#127

and the create_subdir call here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/test/browser/aboutcrashes_utils.js#29

Would probably be sufficient.
Attachment #432866 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/56e32c24f59c

Leaving open for testcase.
Keywords: testcase-wanted
Nah, we have a flag for that. Just close it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite?
Keywords: testcase-wanted
Resolution: --- → FIXED
(Reporter)

Comment 8

8 years ago
Verified with STR from comment 0. Thank you.

Should this go into Lorentz along with bug 544936?
Status: RESOLVED → VERIFIED
Whiteboard: [land lorentz]
Thanks, yes it should.  Reopening for backport.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Once a bug has been resolved on trunk, it is marked RESOLVED FIXED. Any branch-related backports should be tracked with flags or whiteboard notes.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 11

8 years ago
http://hg.mozilla.org/projects/firefox-lorentz/rev/1ae57766034c

This landed well before freeze, I just forgot to update the bug.
Whiteboard: [land lorentz] → [fixed-lorentz]
Blanket approval for Lorentz merge to mozilla-1.9.2
a=beltzner for 1.9.2.4 - please make sure to mark status1.9.2:.4-fixed

Comment 13

8 years ago
Merged into 1.9.2 at http://hg.mozilla.org/releases/mozilla-1.9.2/rev/84ba4d805430
status1.9.2: --- → .4-fixed
You need to log in before you can comment on or make changes to this bug.