RSS feeds sometimes display as summary instead of website

RESOLVED DUPLICATE of bug 550800

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 550800
8 years ago
6 years ago

People

(Reporter: jcranmer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
This has happened to me twice since obtaining 3.0b4: some of my feeds started displaying the items as summaries instead of the webpages (I have a large tranche of feeds, some of which I set to view summaries and others webpages). Flicking the "View Feed Message Body As" to Website, restarting, and reselecting "Default format" caused it to work, although I'm not sure if flicking the pref is necessary.

Unfortunately, I can't provide good STR. I suspect it may be related to gloda, since I recall seeing some indexing messages in the status bar and a gloda failure message in the Error Console the second time, but I'm not sure if that's merely coincidence. It would take more testing to be sure.
(Reporter)

Comment 1

8 years ago
(In reply to comment #0)
> Unfortunately, I can't provide good STR. I suspect it may be related to gloda,
> since I recall seeing some indexing messages in the status bar and a gloda
> failure message in the Error Console the second time, but I'm not sure if
> that's merely coincidence. It would take more testing to be sure.

Nope, not gloda: I disabled the gloda indexing and still saw the error.
(Reporter)

Comment 2

8 years ago
Through repeated use of this JS string:
var scriptLoader = Components.classes["@mozilla.org/moz/jssubscript-loader;1"]
  .getService(Components.interfaces.mozIJSSubScriptLoader);
if (scriptLoader && typeof FZ_NS == 'undefined')
  scriptLoader.loadSubScript("chrome://messenger-newsblog/content/utils.js");
getParentTargetForChildResource(
  "mailbox://nobody@News%20%26%20Blogs-3/CS%20Monitor", FZ_QUICKMODE,
  Components.classes["@mozilla.org/messenger/account-manager;1"]
    .getService(Components.interfaces.nsIMsgAccountManager)
    .FindServer("nobody", "News & Blogs-3", "rss")).Value

I found that the problem is that the value changes from false (don't show summary) to true (show the summory) at some point. I can't debug the RDF at this point, though.

Comment 3

8 years ago
Is this the same as bug 550800?  Are you mixing summary and full-page feeds in the same folder?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550800
You need to log in before you can comment on or make changes to this bug.