"Summary" pref is overridden in multifeed folders

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Feed Reader
--
minor
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: alta88)

Tracking

Trunk
Thunderbird 13.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

20.74 KB, patch
alta88
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.2pre)
 Gecko/20100307 Lanikai/3.1b2pre

If I create an RSS folder and subscribe multiple feeds to it, and ANY feed is set with the "show as summary" option turned OFF, then ALL feed items are shown as Web Page rather than Summary, regardless of the individual setting of the feed.  The Subscribe UI for each individual feed maintains its setting, but it is not possible to mix Summary with Web Page items.

Maybe not such a big deal.  Maybe the UI should be changed to present the option as a folder option rather than a feed option.

Comment 1

6 years ago
Still valid with Seamonkey 2.1 (and before)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 517477
(Assignee)

Comment 3

6 years ago
yes, mixing multifeeds in the same folder will return the summary/web page (quickmode=true for summary) to the first url key encountered in the feeds db.

it would be very difficult to fix this, as it would mean tracking the feed url of a message (not done currently) in either the header or as a msgDbHdr property.  then, all messages would have to be updated if the url ever changed.  very not worth it.

once bug 716706 is checked in, i intend to fix the Subscribe dialog to make it clear that the summary pref updates on a folder level and not feed level.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 513652
(Assignee)

Comment 5

6 years ago
Created attachment 602256 [details] [diff] [review]
patch.


1. the account default can now be updated from the Subscribe dialog.
2. summary checkbox enabled only for folders with feeds; changing the check applies to all feeds in the folder.
3. summary checkbox enabled for folders with feed URL field focused/non empty value, prior to add.
Assignee: nobody → alta88
Attachment #602256 - Flags: review?(dbienvenu)
(Assignee)

Comment 6

6 years ago
Created attachment 602728 [details] [diff] [review]
patch.


updated patch with better keyboard handling and ensuring quickmode is correctly set on dnd operations.
Attachment #602256 - Attachment is obsolete: true
Attachment #602728 - Flags: review?(dbienvenu)
Attachment #602256 - Flags: review?(dbienvenu)

Comment 7

6 years ago
Not sure if this patch is the cause, but now I'm seeing this error when dropping a link to an rss feed:

Timestamp: 3/5/2012 3:47:19 PM
Warning: reference to undefined property this._rowMap[aIndex]._parent
Source File: chrome://messenger/content/folderPane.js
Line: 782

and the feed is not subscribed to. I'll try it w/o this patch.
(Assignee)

Comment 8

6 years ago
i've seen that error, it happens the first time and is an old folderPane.js issue unrelated to any feed work.

also, there is a known issue that the open Subscribe dialog tree map is not updated (first time a dnd on folderpane is done) with the new feed.  if you close/open the dialog to rebuild the tree, it should be there.  if you remove it and repeat the dnd, then the dialog tree updates.

Comment 9

6 years ago
Comment on attachment 602728 [details] [diff] [review]
patch.

usually we say params, not parms, for readability, but I'll leave it up to you.

+   * @param  [aParms] object           - additional parms.
    * @param  [aMode] integer           - action mode (default is kSubscribeMode)
    *                                     of the add.
    * 
    * @return success boolean           - true if edit checks passed and an
    *                                     async download has been initiated.
    */
-  addFeed: function(aFeedLocation, aFolder, aParse, aMode)
+  addFeed: function(aFeedLocation, aFolder, aParse, aParms, aMode)
Attachment #602728 - Flags: review?(dbienvenu) → review+
(Assignee)

Comment 10

6 years ago
Created attachment 603253 [details] [diff] [review]
patch for checkin.


updated per comments.
Attachment #602728 - Attachment is obsolete: true
Attachment #603253 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/ca6a6449f422
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
You need to log in before you can comment on or make changes to this bug.