Closed Bug 517683 Opened 13 years ago Closed 13 years ago

Missing css/icons for Tasks and/or Events sidebar in SeaMonkey with Lightning

Categories

(SeaMonkey :: Themes, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0

People

(Reporter: iannbugzilla, Assigned: philip.chee)

References

(Blocks 1 open bug)

Details

(Keywords: calendar-integration, fixed-seamonkey2.0)

Attachments

(2 files, 3 obsolete files)

In both default and modern themes the Task, Events and Tasks and Events are missing the icons for switching between them and closing that sidebar.
Keywords: modern
Keywords: classic
Lightning uses the sidebar folder cycler CSS from Thunderbird. Since we don't yet have the cycler we don't have the styles to go with it either. Since Mnyromyr did say that we want a folder cycler/picker widget eventually I hope we can get some minimal CSS to support Lightning.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #402579 - Flags: superreview?(neil)
Attachment #402579 - Flags: review?(neil)
Note that there is suite/themes/classic/mac/messenger/mailWindow1.css too.
> Note that there is suite/themes/classic/mac/messenger/mailWindow1.css too.
But I can't test it, so I thought I'd let you do that part instead :)
(In reply to comment #3)
> > Note that there is suite/themes/classic/mac/messenger/mailWindow1.css too.
> But I can't test it, so I thought I'd let you do that part instead :)

It should be quite straightforward just copying the .folderview-cycler style rules  (and icons) from pinstripe.
> It should be quite straightforward just copying the .folderview-cycler style
> rules  (and icons) from pinstripe.
Done! I just cut and paste but I'm a bit dubious about the -moz-image-regions. Perhaps Mac does things differently?
Attachment #402579 - Attachment is obsolete: true
Attachment #403029 - Flags: review?(neil)
Attachment #402579 - Flags: superreview?(neil)
Attachment #402579 - Flags: review?(neil)
(In reply to comment #5)
> Created an attachment (id=403029) [details]
> Patch vC1.1 Folder Cycler styles inc Mac.
> 
> > It should be quite straightforward just copying the .folderview-cycler style
> > rules  (and icons) from pinstripe.
> Done! I just cut and paste but I'm a bit dubious about the -moz-image-regions.
> Perhaps Mac does things differently?

Thanks for doing it :-) No, mac does not do things differently in this case. You are probably thinking of the issue with -moz-image-region in native mac menus (that is, menus in the windows menubar which are done by the widget code).
Comment on attachment 403029 [details] [diff] [review]
Patch vC1.1 Folder Cycler styles inc Mac.

>+.folderview-cycler,
>+.folderview-cycler .toolbarbutton-icon,
>+.folderview-cycler .toolbarbutton-text {
These need to use > (and the text should be display: none?)

>+.folderview-cycler[dir="prev"],
>+.folderview-cycler[dir="next"][chromedir="rtl"] {
>+  list-style-image: url("chrome://messenger/skin/icons/spin-buttons.png");
Why are we using these images rather than the global arrow.css images?

>+  padding: 0 !important;
>+  margin: 0 !important;
Aren't you repeating yourself?

>+  -moz-margin-end: 4px !important;
Why?

>+sidebarheader .toolbarbutton-text:not(value) {
Should be .folderview-cycler > .toolbarbutton-text

>+.folderview-cycler {
>+  -moz-padding-end: 0px;
I think this needs to be
.folderview-cycler > .toolbarbutton-icon {
  margin: 0px; /* !important ? */
}

(Same applies to Modern of course.)
Attachment #403029 - Flags: review?(neil) → review-
Duplicate of this bug: 519178
> >+.folderview-cycler,
> >+.folderview-cycler .toolbarbutton-icon,
> >+.folderview-cycler .toolbarbutton-text {
> These need to use >
Fixed.

> (and the text should be display: none?)
Fixed.

> >+.folderview-cycler[dir="prev"],
> >+.folderview-cycler[dir="next"][chromedir="rtl"] {
> >+  list-style-image: url("chrome://messenger/skin/icons/spin-buttons.png");
> Why are we using these images rather than the global arrow.css images?

Thunderbird switched from arrow graphics to custom spin images in Bug 366842 (Land Pinstripe Theme Update for Mac OS X)

> >+  padding: 0 !important;
> >+  margin: 0 !important;
> Aren't you repeating yourself?
Removed.

> >+  -moz-margin-end: 4px !important;
> Why?
No idea. I don't have a Mac to test. Anyway removed. Lets see if Stefan will complain.

> >+sidebarheader .toolbarbutton-text:not(value) {
> Should be .folderview-cycler > .toolbarbutton-text
Fixed.

> >+.folderview-cycler {
> >+  -moz-padding-end: 0px;
> I think this needs to be
> .folderview-cycler > .toolbarbutton-icon {
>   margin: 0px; /* !important ? */
> }
Fixed (!important didn't seem necessary).

> (Same applies to Modern of course.)
Fixed.
Attachment #403029 - Attachment is obsolete: true
Attachment #403442 - Flags: review?(neil)
As discussed over IRC with Neil. Here is an alternative for the Mac Cycler using the global arrow images. Obviously not tested at all.

+.folderview-cycler[dir="prev"]:active,
+.folderview-cycler[dir="next"][chromedir="rtl"]:active {
+  list-style-image: url("chrome://global/skin/arrow/arrow-lft-hov.gif");
+}
+
+.folderview-cycler[dir="next"]:active,
+.folderview-cycler[dir="prev"][chromedir="rtl"]:active {
+  list-style-image: url("chrome://global/skin/arrow/arrow-rit-hov.gif");
+}

Just a wild guess as to what to use for the :active images.
Attachment #403443 - Flags: review?(stefanh)
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]

requesting review from Stefan for the Mac cycler.
Attachment #403442 - Flags: review?(stefanh)
Attachment #403443 - Flags: review?(neil)
Attachment #403443 - Flags: review?(neil) → review+
Attachment #403442 - Flags: review?(neil) → review+
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]

I've tried both patches and I think the pinstripe icons are better suited. They're not optional, but the problem with the global images is that they seem to look a bit smaller and more "plain" than the other arrows used to shift days. I have nothing against plain arrows, but it just feels that the cycler arrows should be larger. There's also no real hover:active icon since that one should ideally be darker.
Attachment #403442 - Flags: review?(stefanh) → review+
Attachment #403442 - Flags: superreview?(neil)
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]

> I've tried both patches and I think the pinstripe icons are better suited.
Since Stefanh likes this one better, requesting sr.
Attachment #403443 - Attachment is obsolete: true
Attachment #403443 - Flags: review?(stefanh)
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]

>+  padding: 0 !important;
>+  margin: 0 !important;
>+  border: none !important;
Bah, I forgot to ask whether these were... important ;-)
Attachment #403442 - Flags: superreview?(neil) → superreview+
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]

>>+  padding: 0 !important;
>>+  margin: 0 !important;
>>+  border: none !important;
> Bah, I forgot to ask whether these were... important ;-)
I was going to ask Stefan this as well, but I forgot too.
Attachment #403442 - Flags: approval-seamonkey2.0?
Attachment #403442 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Attachment #403442 - Attachment description: Patch vC1.2 Fix review comments. → [for checkin] Patch vC1.2 Fix review comments.
Keywords: checkin-needed
I tried applying this patch on my Debian machine with Seamonkey 21a1Pre, but that does not seems to work. Can some one confirm whether this had been tried with Linux and anything other than applying the patch needs to be done.
This patch adds the cycler images to the Today pane panel and doesn't address any other UI problems. Also you need to have a recent nightly build of Lightning 1.0pre.
Comment on attachment 403442 [details] [diff] [review]
Patch vC1.2 Fix review comments
[Checkin: Comment 19]


http://hg.mozilla.org/comm-central/rev/681e87a38edb
Attachment #403442 - Attachment description: [for checkin] Patch vC1.2 Fix review comments. → Patch vC1.2 Fix review comments [Checkin: Comment 19]
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
Got it working. It should have been working when I first compiled itself, but it just that the buttons are not visible. Only when I hover over the buttons, it is visible. Thanks a lot.
> Got it working. It should have been working when I first compiled itself, but
> it just that the buttons are not visible. Only when I hover over the buttons,
> it is visible. Thanks a lot.

That should not be the case. They should always be visible. If you know how to use the DOM Inspector, you can use it to see what CSS file/rule is interfering with the rules in this patch.
You need to log in before you can comment on or make changes to this bug.