staragon.com - [LAYER] Left frame does not scroll in Mozilla browser

RESOLVED FIXED

Status

P4
minor
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: sarah.livengood, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-DOM][aok][havefix][havecontact][bug248549notfixed], URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.59 KB, application/x-javascript
Details
(Reporter)

Description

18 years ago
This left frame of this page contains a scrolling gif using the javascript 
document.all()which Mozilla doesn't support.  The frame still displays, it just 
doesn't scroll as it does in IE or Netscape 4.5.
 
Tested on Mozilla build M18 2000-09-07-08, Linux.
(Reporter)

Comment 1

18 years ago
Changed resolution to Invalid per uses document.all()script that Mozilla does 
not support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
reopening for evangelism at a later date
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

18 years ago
sigh
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 5

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 6

18 years ago
Arun, I'm giving you all the Linux bugs. If these bugs can be confirmed for
other OS's please (someone) change the Platform/OS to All/All and reassign to
the default Evangelism Component Owner.
Assignee: bclary → aruner

Comment 7

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 8

17 years ago
Arun, I am taking your Linux bugs minus banks. Hope you don't mind.
Assignee: aruner → bclary

Updated

17 years ago
Summary: [LAYER] Left frame does not scroll in Mozilla browser → staragon.com - [LAYER] Left frame does not scroll in Mozilla browser

Updated

17 years ago
Severity: normal → minor
OS: Linux → All
Whiteboard: [PROPRIETARY-DOM][aok]

Comment 9

17 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr
now it's totally gone.
This is a European Site (Spanish) moving to TE Western Europe
Component: US General → Europe: West
assigning to Tristan Nitot since it is his geographic area, CCing Mat.
Contact is : informa@aragonaventura.es 

Javascript involved :

 <script language="JavaScript"><!--
var ver = 3
bVer = parseInt(navigator.appVersion);
if(bVer >= 4)  ver = 4

var ns = navigator.appName == "Netscape";
var ie = navigator.appName == "MSIE";



var pix = 15;           // nþmero de pixeles por cada frame
var rate = 20;         // frames por segundo
var ImgHeight = 600;   // ancho de la tira



var time = 1000/rate;
var again = - ImgHeight


function tick() {

if (ver ==3) return

if (ns){
	document.Layer1.offset(0,-pix);

	document.Layer2.offset(0,-pix);

	if (document.Layer1.top <= again) document.Layer1.top = ImgHeight;

	if (document.Layer2.top <= again) document.Layer2.top = ImgHeight;
	
}
else {
	newpix = document.all["Layer1"].style.pixelTop - pix;
	newpix2 = document.all["Layer2"].style.pixelTop - pix;

	document.all["Layer1"].style.pixelTop = newpix;

	document.all["Layer2"].style.pixelTop = newpix2;

	if (document.all["Layer1"].style.pixelTop <= again)
document.all["Layer1"].style.pixelTop = ImgHeight;

	if (document.all["Layer2"].style.pixelTop <= again)
document.all["Layer2"].style.pixelTop = ImgHeight;
	}	

	setTimeout('tick()', time);
}
Assignee: doron → nitot
this is really minor (I prefer it not to scroll :)
working on a fix anyway
Priority: P3 → P4
Created attachment 91492 [details]
fix

linking to this script instead of using their javascript code in
http://www.staragon.com/aragonaventura/lateral.htm makes the trick.
contact :informa@aragonaventura.es
Whiteboard: [PROPRIETARY-DOM][aok] → [PROPRIETARY-DOM][aok][havefix][havecontact]
can anyone speaking spanish contact them ?
Mat, your fix makes the image scroll in gecko but it stops after a few seconds.
I don't know enough of javascript to find where the error is.
Created attachment 100529 [details]
updated fix

yup, there was a typo ("1" instead of "2" ... yes, one character change :) ...
thanks pascal for pointing that out. this one should work.
Attachment #91492 - Attachment is obsolete: true
I sent a letter to the webmaster
did he even answer?
nope
New Component
Component: Europe: West → Spanish

Comment 23

15 years ago
spanish default owner
Assignee: nitot → spanish
QA Contact: zach → spanish

Updated

14 years ago
Whiteboard: [PROPRIETARY-DOM][aok][havefix][havecontact] → [PROPRIETARY-DOM][aok][havefix][havecontact][bug248549notfixed]

Comment 24

13 years ago
I send a e-mail to soaso@staragon.com. I found this e-mail in the metadata of the web. Probably is the webmaster e-mail.

Comment 25

11 years ago
This looks like it's FIXED; I don't see any frames at all any more.
Status: NEW → RESOLVED
Last Resolved: 18 years ago11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.