Fith and subsequent filter conditions appear blank when edited

RESOLVED DUPLICATE of bug 506199

Status

RESOLVED DUPLICATE of bug 506199
9 years ago
8 years ago

People

(Reporter: roy.trubshaw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Lightning/1.0pre Thunderbird/3.0b3

When editing a filter that has more than four conditions the fifth and subsequent condition is blank.

Specifically: the first field contains a greyed-out "Missing Custom Term", the condition field is blank and narrowed vertically, the third field is blank, but full height.

msgFilterRules.dat does not seem to contain anything untoward and altering the order of the conditions does not affect the behaviour of the application.

Reproducible: Always

Steps to Reproduce:
1.  Open Tools|Message Filters...
2.  Click New...
3.  Name it
4.  Add text to final field (leaving default of "Subject", "contains")
5.  Click "+"
6.  Repeat step 4. a further four or more times.
7.  Choose a target folder (leaving default action of "Move Message to")
8.  Click "OK"
9.  Select newly created filter.
10. Click Edit...
11. Scroll the conditions list
Actual Results:  
5th and subsequent conditions are blank

Expected Results:  
To see the 5th and subsequent condition as entered

Filters are applied correctly including the conditions that are not editable in the UI

Comment 1

9 years ago
I believe this has been fixed for b4, and is a dup
Whiteboard: dupeme
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> I believe this has been fixed for b4, and is a dup

I searched for several hours, over a period of a week in an effort to find an existing report of this bug. I'd be pleased if you could indicate the report of which this is a duplicate.
DUP of Bug 506199.

(In reply to comment #2)
> I searched for several hours, over a period of a week in an effort to find an existing report of this bug.

Have you searched for already fixed bugs and DUP closed bugs, which were recently changed, using advanced search? ( Resolution: / Bug Changes, Only bugs changed between: )
Because many bugs are fixed daily, search for fixed bug is needed. And, because many DUP bugs are opened daily and many bugs are closed as DUP daily, search for DUPed bugs will help searching. And, because too many bugs exist at B.M.O, limiting to "Recently changed" is required for useful search.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 506199

Comment 5

9 years ago
Roy, I just happened to know it was a dupe of a fixed bug because I remember the code change get checked in, but I didn't know the bug #...
You need to log in before you can comment on or make changes to this bug.