GetURL & OpenURL having termination issues.

VERIFIED DUPLICATE of bug 48887

Status

SeaMonkey
General
P3
major
VERIFIED DUPLICATE of bug 48887
18 years ago
14 years ago

People

(Reporter: chris_mccurdy, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2000081721

The AppleScript OpenURL and GetURL interface is broken.  There appears to be 
some code that removes a null terminator.

Reproducible: Always
Steps to Reproduce:
1.Create the following AppleScript

tell application "mozilla"
  openurl "http://www.google.com/"
end tell

2. It won't open the proper url, it will open something equivolent to
http://www.google.com%20%30....


Actual Results:  It didn't open the given URL.					
	

Expected Results:  It should have opened the URL.

No.

Comment 1

18 years ago


*** This bug has been marked as a duplicate of 48887 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
This is a dup of bug 48887:GetURL AppleEvent cuts off last character of URL
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.