Last Comment Bug 518134 - Enabled column in Message Filters does not track dialog size properly
: Enabled column in Message Filters does not track dialog size properly
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Filters (show other bugs)
: 1.9.1 Branch
: x86 Windows XP
: -- normal (vote)
: Thunderbird 3.1b2
Assigned To: Kent James (:rkent)
:
:
Mentors:
http://gsfn.us/t/pj7x
: 537487 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-22 09:43 PDT by MrC
Modified: 2010-04-29 13:01 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.5-fixed


Attachments
screen shot (14.00 KB, image/png)
2009-11-03 17:22 PST, A. Shimono [:himorin]
no flags Details
Simulated problem (36.44 KB, image/jpeg)
2010-02-11 01:20 PST, Kent James (:rkent)
no flags Details
Simulated solution: min-width=40 (38.05 KB, image/jpeg)
2010-02-11 01:25 PST, Kent James (:rkent)
no flags Details
min-width=40 (1.68 KB, patch)
2010-02-11 01:42 PST, Kent James (:rkent)
mkmelin+mozilla: review+
Details | Diff | Splinter Review
use xul attribute instead of css (1019 bytes, patch)
2010-04-05 00:41 PDT, Kent James (:rkent)
mkmelin+mozilla: review+
standard8: approval‑thunderbird3.0.5+
Details | Diff | Splinter Review

Description MrC 2009-09-22 09:43:34 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090922 Shredder/3.0pre

The Enabled column does not position properly when the dialog is widened,
and then width decreased.  

Reproducible: Always

Steps to Reproduce:
1.Increase the Message Filters dialog width to be wider than the number of items, so that no scrollbar appears.  Any scrollbar repainting prevents the
problem from being exhibited.
2. Now reduce the dialog width (don't decrease the height of the dialog).
3.Note how the Enabled column's checkboxs are missing.  Decreasing the height of the dialog (to that which will cause scrollbars to be created) will move the Enabled checkboxes to within the dialog.
Actual Results:  
Dialog's Enabled checkboxes are not shown within the dialog (nor are under the Enabled column).

Expected Results:  
Enabled checkboxes should always appear under the Enabled column.  Repainting of the dialog contents should occur as the dialog is resized.
Comment 1 MrC 2009-09-22 09:45:24 PDT
FYI: I first mentioned this bug (as item #2) in bug 517617 (that bug is now resolved).
Comment 2 Kent James (:rkent) 2009-09-22 13:04:04 PDT
I can confirm this happens. I've never been able to unravel the mysteries of the filter editor CSS, however.
Comment 3 A. Shimono [:himorin] 2009-11-03 17:22:59 PST
Created attachment 410092 [details]
screen shot

I confirm this w/ 20091014, 20091103 nightly.
Mozilla/5.0 (Windows; U; Windows NT 6.0; ja; rv:1.9.1.6pre) Gecko/20091103 Shredder/3.0pre

Decreasing and Increasing (or maximize the window) does not resolve this.
Comment 4 WADA 2010-01-03 23:24:30 PST
*** Bug 537487 has been marked as a duplicate of this bug. ***
Comment 5 WADA 2010-01-03 23:33:30 PST
Workaround:
  1. Reduce panel width to normal size => check box is hidden
  2. Change focus to other, then move focus back to filter list
  2-a. Click title bar or status bar, then click filter list box
  2-b. Expand selection list(Filters for:/Run selected folders on:) and close
  2-c. Click column header(Filter Name, Enabled)
  => Check box re-appears.
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2010-01-30 08:14:41 PST
I can't reproduce this in v2.0.0.21, so => regression
core or theme bug?  
- https://bugzilla.mozilla.org/buglist.cgi?short_desc=css%20width;bug_severity=major;bug_severity=normal;resolution=---;query_format=advanced;short_desc_type=allwordssubstr;product=Core;product=Firefox
- is it definitely a css issue? 

littlebird theme 1.8.56 https://addons.mozilla.org/en-US/thunderbird/addon/1493  on 2 machines is slightly different, and makes using littlebird unusable for me, but maybe it's because the Enable column checkbox is just missing. 

On desktop I immediately see attachment (id=410092) without resizing.
On my laptop at home, I don't see the slider column go underneath Enable column ever.

3.0.1
Comment 7 Kent James (:rkent) 2010-01-30 11:20:23 PST
I've seen this reported several times in support forums, so I thing that I need to look at it some more.
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2010-01-30 11:33:49 PST
hook up go gsfn http://gsfn.us/t/pj7x
Comment 9 Kent James (:rkent) 2010-02-11 01:13:00 PST
There are definitely some strange behaviors in the way that the "enable" column displays. For example, if you expand the width of the filter list dialog, then shrink it, then expand it, then the enabled column does not reappear until the width returns to its widest value. You can keep making it wider and wider, until eventually the only time the enable column appears is when the width is at its widest. To make the enable column reappear normally, what you need to do is to set the width of the filter list dialog to a normal value, close it, the reopen it again.

But that is not what is going on here. If the width of what would be in English the "Enabled" text is very small, as it is in Japanese, and the number of filters is so large that a scroll bar is needed, then the scroll bar covers up the "Enabled" columns completely, regardless of the width of the filter list dialog.

I can simulate that by replacing "Enabled" with "A". See the attached screenshot. For my simulation, I can then fix the problem by adding a minimum width to the listheader element. That is what I will do in a patch.
Comment 10 Kent James (:rkent) 2010-02-11 01:20:16 PST
Created attachment 426470 [details]
Simulated problem
Comment 11 Kent James (:rkent) 2010-02-11 01:25:32 PST
Created attachment 426471 [details]
Simulated solution: min-width=40
Comment 12 Kent James (:rkent) 2010-02-11 01:42:23 PST
Created attachment 426473 [details] [diff] [review]
min-width=40
Comment 13 Alfred Kayser 2010-02-11 07:22:34 PST
The patch doesn't fix everything.
Resize the dialog box bigger (much bigger), and than much smaller.
The enabled checkmarks still disappear, and won't back easily...
Comment 14 Kent James (:rkent) 2010-02-11 10:52:00 PST
(In reply to comment #13)
> The patch doesn't fix everything.
> Resize the dialog box bigger (much bigger), and than much smaller.
> The enabled checkmarks still disappear, and won't back easily...

That was one of the main points of my comment 9, that there are multiple issues, but I would like to focus on just one here (which it what the OP showed) to make some progress. The issue I addressed in the patch is rarer than the one described in comment 9 and comment 12, but it has no easy workaround unlike that issue.
Comment 15 Magnus Melin 2010-02-14 11:17:00 PST
Comment on attachment 426473 [details] [diff] [review]
min-width=40

I'm not really able to reproduce the problem this would fix. (Though there's obviously a lot of wackiness there.) 

Not that is would break anything either. How about a minwidth attribute in xul instead though?
Comment 16 Kent James (:rkent) 2010-02-14 13:15:31 PST
To reproduce, I made a custom XUL file to replace the "enabled" text. Not optimal I realize. Tried to load Japanese, but it was clear it was going to need more than just installing the downloaded file to get it to work on my system.

By "minwidth attribute in xul" do you mean hardwired in the .xul file, instead of adding it as a style? It's all the same to me, but I am not really that familiar with the standard expectations of what goes where in XUL and CSS.

This seems low risk to solve a problem which is quite severe in Japanese looking at the example, but it is rare otherwise. As you say there is plenty of wackiness beyond this issue, which is also the point of comment 13.
Comment 17 Arnaud Ladrière 2010-02-26 06:36:03 PST
Hello

this problem also does occur with european characters, once the number of filters is too big to fit in one window (which is the case for several of my mailboxes)
Comment 18 Kent James (:rkent) 2010-02-26 09:09:10 PST
With Arnaud's ping, I realize this patch is left hanging. Mkmelin, could you answer my question in comment 15? Added you to the cc list to make sure you are getting this.
Comment 19 Magnus Melin 2010-02-26 09:59:42 PST
Comment on attachment 426473 [details] [diff] [review]
min-width=40

Sorry, missed it since i forgot to cc in.

I'd prefer the xul approach, especially to avoid having 3rd party themes bitten by it.
Comment 20 Kent James (:rkent) 2010-04-05 00:41:53 PDT
Created attachment 436995 [details] [diff] [review]
use xul attribute instead of css

I revised this patch to move the minwidth into the xul attribute, as requested.
Comment 21 Kent James (:rkent) 2010-04-07 07:52:37 PDT
Comment on attachment 436995 [details] [diff] [review]
use xul attribute instead of css

Checked in http://hg.mozilla.org/comm-central/rev/083e3dae4e99
Comment 22 Kent James (:rkent) 2010-04-07 08:04:20 PDT
Comment on attachment 436995 [details] [diff] [review]
use xul attribute instead of css

checked in http://hg.mozilla.org/comm-central/rev/083e3dae4e99
Comment 23 Kent James (:rkent) 2010-04-29 13:00:00 PDT
Comment on attachment 436995 [details] [diff] [review]
use xul attribute instead of css

Checked in http://hg.mozilla.org/releases/comm-1.9.1/rev/15da4205b86b

Note You need to log in before you can comment on or make changes to this bug.