Text cursor vanishes when composing message

VERIFIED DUPLICATE of bug 52150

Status

P2
major
VERIFIED DUPLICATE of bug 52150
18 years ago
10 years ago

People

(Reporter: metrol, Assigned: saari)

Tracking

({regression})

Trunk
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
This one JUST showed up in build 2000090704, as I just got through composing
messages in the previous day's build without this problem.  It has a problem in
both HTML and plain text editing.

To replicate: Open a new message composition window.  Type a few lines, then
press enter to get yourself down about 15-20 lines.  Continue typing, and you'll
notice that the cursor is no longer visible.

Comment 1

18 years ago
A fix was checked in some hours later.
Dup of 51747 "Caret doesn't render at the end of line."

*** This bug has been marked as a duplicate of 51747 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
Although the cursor problem reported in Bug 51747 appears to have been fixed,
the problem got a whole lot worse for Composer.  I'm no longer getting any
cursor at all in there.  Mail composition now appears to be working correctly.
These look related, and the symptoms spelled out in this bug have a closer
resemblance to what I'm seeing with Composer than 51747.

BTW, shouldn't I be able to change the component this bug effects?  When trying
to change the Product to Browser the Components listing doesn't update.  Is this
a Bugzilla bug that needs reported, or am I missing something?

Reopening bug, and adding myself to the cc.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
reassign to editor team
Assignee: ducarroz → beppe
Status: REOPENED → NEW

Comment 4

18 years ago
i believe sfraser was working on this
Assignee: beppe → sfraser
Keywords: nsbeta3, regression
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 5

18 years ago
This is a dup of the focus bug relating to new composer/message windows. Can't
find the bug right now.
(Reporter)

Comment 6

18 years ago
New twist to this bug as of build 2000091108.  When opening up a new composition
window the cursor is with the ya the whole time, and everything looks to be
working as it should.  Replying to a Usenet post though brings up a composition
window without any cursor at all.  Composer itself still have no cursor at any
point.

Updated

18 years ago
QA Contact: lchiang → esther

Comment 7

18 years ago
kin, sfraser debugged, it seems to be a focus issue, assigning to saari, cc
trudelle. saari sfraser can help explain the underlying issue
Priority: P3 → P2
Whiteboard: [nsbeta3+]

Comment 8

18 years ago
really reassign
Assignee: sfraser → saari

Comment 9

18 years ago
nsbeta3+
Whiteboard: [nsbeta3+]

Comment 10

18 years ago
To see what's happening, here, add this CSS to your global.css file in the skin 
you are using:

:focus {
    -moz-outline: thin dotted red !important;
}

Now, in a mail compose window, do the following:

1. click in subject line to focus it. Note the red border.
2. hit tab to focus the content. Note that the content is momentarily focussed
   (the caret appears briefly, menus briefly enable on Mac), then focus bounces
   back to the container for the subject line (the red outline goes back to
   the subject, but is slightly bigger than before).

So, focus is royally hosed in this window.

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 52150 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 12

18 years ago
Fixed the problem in mail compose, a JS typo. Composer looks like a different 
issue.

Comment 13

18 years ago
Verified as duplicate as bug 52150.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.