Last Comment Bug 519137 - Remove keyboard shortcut F1 (Help)
: Remove keyboard shortcut F1 (Help)
Status: RESOLVED FIXED
: user-doc-needed
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 3.7a1
Assigned To: Mike Connor [:mconnor]
:
Mentors:
Depends on:
Blocks: 763733
  Show dependency treegraph
 
Reported: 2009-09-27 16:25 PDT by David Tenser [:djst]
Modified: 2012-06-11 17:30 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove F1 keybinding (2.63 KB, patch)
2009-11-27 11:47 PST, Mike Connor [:mconnor]
gavin.sharp: review+
Details | Diff | Splinter Review

Description David Tenser [:djst] 2009-09-27 16:25:32 PDT
Thanks to bug 489245 and bug 498920, we have been able to verify a theory that many people are hitting F1 by accident. 

We set up separate target pages for people who arrived on support.mozilla.com by selecting Help > Firefox Help from the menu vs people who arrived there by pressing F1.

The results for September:

* For people using the Help menu, the bounce rate was 32.3%
* For people pressing F1, the bounce rate was 98.2%!

These results clearly show that the user does not intend to open the support website by pressing F1 -- it is reasonable to believe that the F1 keystroke was accidental, e.g. when the user was typing.

The keyboard shortcut F1 should be removed from Firefox.
Comment 1 Tanner Filip [:tanner] 2009-09-27 16:30:03 PDT
Yeah, i agree. 98% accidental is a bit high...
Comment 2 Ria Klaassen (not reading all bugmail) 2009-09-28 07:23:49 PDT
Interesting would be to know how many help seekers the 1.8% keyboard F1 hits represent in relation to the 67.7% Help menu clickers.
Will Help get a different key assigned? Then it won't be consistent anymore with Internet Explorer, Opera and Google Chrome.
Comment 3 David Tenser [:djst] 2009-09-28 07:44:46 PDT
(In reply to comment #2)
> Interesting would be to know how many help seekers the 1.8% keyboard F1 hits
> represent in relation to the 67.7% Help menu clickers.

I don't think it's safe to assume that the 1.8% that do interact with the page do it because they expected help to load when the F1 key was pressed -- it could still have been an accident. However, to answer your question, based on the stats for last week:

* 1,714,803 page views from F1
  98.2% bounced = ca 31k people used the page
* 194,087 page views from the Help menu
  32.5% bounced = 131k people used the page
Comment 4 Ria Klaassen (not reading all bugmail) 2009-09-28 09:09:48 PDT
So that is 19% keyboard and 81% help menu.

> I don't think it's safe to assume that the 1.8% that do interact with the page
> do it because they expected help to load when the F1 key was pressed -- it
> could still have been an accident. 

You mean that they browse around on the support page. The same goes for the Help menu clickers. Both are interested enough to use the page. :)
Comment 5 Ria Klaassen (not reading all bugmail) 2009-09-28 10:01:32 PDT
Please correct me if I'm wrong. So there are 1.683.936 unintended visits of the support page per week, = per year 87.564.672 visits. 

There are 270.000.000 Firefox users ( http://www.downloadsquad.com/2009/05/05/how-many-firefox-users-are-there-mozilla-estimates-270-million/ )

So that would mean that once in about 3 years someone hits unintentionally F1. Whether or not all those visits are unintended you can only know by means of a poll, for I can imagine that a user just wants to know what's underneath the F1 key.
Comment 6 Ria Klaassen (not reading all bugmail) 2009-09-28 10:58:12 PDT
(In reply to comment #3)
 
> * 1,714,803 page views from F1
>   98.2% bounced = ca 31k people used the page
> * 194,087 page views from the Help menu
>   32.5% bounced = 131k people used the page

Is this all languages?
Comment 7 u88484 2009-09-28 11:55:27 PDT
Fixing bug 475358 would probably help out a whole lot due to cats and other cirumstances that the F1 key was accidently held down.  I'd also vote for removing this shortcut as support is easily accessible through the menu labeled 'Help'.
Comment 8 Tanner Filip [:tanner] 2009-09-28 13:22:12 PDT
This is just an idea, but how about something like Ctrl+Alt+H replacing F1?
Comment 9 David Tenser [:djst] 2009-10-14 08:49:20 PDT
(In reply to comment #6)
> (In reply to comment #3)
> 
> > * 1,714,803 page views from F1
> >   98.2% bounced = ca 31k people used the page
> > * 194,087 page views from the Help menu
> >   32.5% bounced = 131k people used the page
> 
> Is this all languages?

Just en-US.

Regarding comment 5, the following analysis was also made in addition to the bounce rate test: http://blog.mozilla.com/metrics/2009/08/18/cats-love-firefox-support/
Comment 10 Mike Connor [:mconnor] 2009-11-27 11:47:50 PST
Created attachment 414865 [details] [diff] [review]
remove F1 keybinding

not properly tested since I don't have a Windows box here.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-11-27 12:01:59 PST
Comment on attachment 414865 [details] [diff] [review]
remove F1 keybinding

>diff --git a/browser/base/content/baseMenuOverlay.xul b/browser/base/content/baseMenuOverlay.xul

>         <menuitem id="menu_openHelp"

>-                  key="key_openHelp"/>

A lot of themes style this menuitem using this attribute (because it didn't used to have an ID, I think?), so perhaps we should leave it despite it not doing anything... Or maybe we shouldn't care, assuming this only goes in on trunk.
Comment 12 Mike Connor [:mconnor] 2009-11-27 12:52:29 PST
http://hg.mozilla.org/mozilla-central/rev/c3813801ed06

I don't think we should leave it in, especially since it differs between Mac and non-Mac.  People should use the id.  But, won't land this on branches, since some people are indeed using this.
Comment 13 dickvl 2009-11-27 19:58:19 PST
Maybe restore the old F1 Help pop-up window and place an explanation in that window that Help is now online and a button to go to that online Help page.
Comment 14 Alice0775 White 2009-11-27 20:45:17 PST
(In reply to comment #1)
> Yeah, i agree. 98% accidental is a bit high...

No, I don't think so.
In most applications on Windows, F1 is HELP.
This fix spoils conventional experience.
Comment 15 David Tenser [:djst] 2009-11-30 07:00:45 PST
(In reply to comment #14)
> No, I don't think so.
> In most applications on Windows, F1 is HELP.
> This fix spoils conventional experience.

This convention has existed since 1987, but that doesn't say anything about its usefulness. 

I don't know of any previous research about how people commonly (mis)use the keyboard, but the high bounce rate here is evidence enough that the F1 binding is flawed: with a 98% accidental hit rate, it's pretty clear that Help is not what the user intended when hitting F1.
Comment 16 Steffen Wilberg 2009-12-02 07:25:55 PST
Need to update the keyboard shortcuts page on sumo for 3.7.
Comment 17 Boersenfeger 2010-08-19 06:18:08 PDT
(In reply to comment #16)
I found this option very helpful and I regret that it no longer works in version 4.0b *. I am a German translator for the SUMO project and member of the German Firefox forum. www.camp-firefox.de/forum
We often give an indication of the F1 Key and the users say thank you and look forward to that one is accustomed as fast as WINDOWS, on the help pages. In version 3.6.8 of the button click still worked. Now in Firefox 4.0b * unfortunately not more. Please re-implement this useful feature. Thank you!

Note You need to log in before you can comment on or make changes to this bug.