"Unexpected error has occurred" trying to load RSS feed for solved forum post

VERIFIED FIXED in 1.4.1

Status

--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: stephend, Assigned: paulc)

Tracking

unspecified
1.4.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nofennec tiki_bug tiki_upstreamed, URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
STR:

While logged out, load http://support-stage.mozilla.org/tiki-forum_rss.php?locale=en-US&forumId=1&comments_parentId=446820

Expected:

RSS feed of forum posts for http://support-stage.mozilla.org/en-US/forum/1/446820

Actual:

"Error

An unexpected error has occurred!"
(Assignee)

Comment 1

9 years ago
This happens only when logged out. I've seen this bug and I thought I fixed it but I guess not. Taking.
Assignee: nobody → paulc
(Reporter)

Updated

9 years ago
Summary: Unexpected error has occurred trying to load RSS feed for solved forum post → "Unexpected error has occurred" trying to load RSS feed for solved forum post
(Reporter)

Updated

9 years ago
Blocks: 519335
(Assignee)

Comment 2

9 years ago
Created attachment 403519 [details] [diff] [review]
patch, v1

Thanks to jsocol for debriefing me about insert ignore, this is a really simple fix. Additionally, the uniqueid column is limited to 30 (!!) characters, so the previous construction was too long. I changed it to something shorter.
Attachment #403519 - Flags: review?(james)
Comment on attachment 403519 [details] [diff] [review]
patch, v1

WFM.

Did notice a new bug, though, bug 519569.
Attachment #403519 - Flags: review?(james) → review+
(Assignee)

Comment 4

9 years ago
r52584 / r52585

Fennec is out of date, so I didn't commit there. We'll do a merge later, as discussed in the SUMOdev meeting today.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
Verified FIXED on http://support-stage.mozilla.org/tiki-forum_rss.php?locale=en-US&forumId=1&comments_parentId=446820, logged out and in.
Status: RESOLVED → VERIFIED
Target Milestone: --- → 1.4.1
(Assignee)

Updated

9 years ago
Whiteboard: nofennec

Comment 6

9 years ago
Is this something that should be upstreamed to Tiki?
Whiteboard: nofennec → nofennec sumo_triage
(Assignee)

Comment 7

9 years ago
It is a problem, although not too big. This arose from table database columns being restricted too short and me not being careful about it. So, it's not really a problem for Tiki I suppose.

Updated

9 years ago
Whiteboard: nofennec sumo_triage → nofennec tiki_bug
Could not reproduce in trunk. Might already be fixed.
Whiteboard: nofennec tiki_bug → nofennec tiki_bug tiki_upstreamed
You need to log in before you can comment on or make changes to this bug.