Closed Bug 519675 Opened 10 years ago Closed 10 years ago

"You" is ambiguous when dealing with multiple accounts

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 478466

People

(Reporter: BenB, Unassigned)

Details

followup to bug 457304 comment 14 ff.

The new mail header pane shows just "You" in the To fields for your own address, instead of email address or name. "Your own address" is determined by the identities configured.

That's a fine idea, however it causes a problem when I have multiple identities configured, because I have multiple roles (e.g. private vs. work, working for 2 companies, or customerservice@ vs. press@) and want them separated. In this case, I often want or *need* (see press@) to know which address the email went to.

Currently, I can't easily, because TB just shows "You". If there are multiple identities configured, it should be more sepcific than "You", but rather show the identity name or email address (my preference) that was used to address me.

In other words, when there are multiple identities / email address, and they are all replaced with just "You", we strictly lose information, and information that users do care about.

---

Note that there can be several identities per account, so using the account name (e.g. "You (Vincent)", where "Vincent" is the account name) is not sufficient, because the user is very likely to really care about which of the identities is used, given that he explicitly configured several (and probably uses in the Composer).

Easiest would be to just use email addresses: "You <ben@company-a.com>".
If there's only one identity per account, we could use the account name, but that by default is the email address: "You (ben@company-a.com)" or (if I gave a nice account name): "You (Company A)".
Identities can't have names (at least not in current UI), so we'd have to use email addresses, of there are several identities per account, or we generate a name, by looking at all identity email addresses and use only the local part, only the domain, or the full address, depending on what differs between them, e.g. fred.flintstone@gmail.com and fred.flintstone@verizon.net and thesofthardguy@hotmail.com -> "You (gmail.com)" and "You (verizon.net)" and "You (hotmail.com)" or sales@company-a.com and info@company-a.com -> "You (sales)" and "You (info)".
But as I said, just using the email address is easiest.
This has been filed already as bug 478466 almost immediately once that feature was established, thus duping.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: me-header
Thanks.
verify.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.