Closed Bug 519886 Opened 12 years ago Closed 12 years ago

Topcrash [@ nsScriptLoader::StartLoad(nsScriptLoadRequest*, nsAString_internal const&)]

Categories

(Core :: DOM: HTML Parser, defect, P2)

x86
All
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.2
Tracking Status
status1.9.2 --- beta2-fixed
status1.9.1 --- .6-fixed

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

(Keywords: crash, topcrash, Whiteboard: [sg:dos][crashkill][crashkill-fix][crashkill-thirdparty] null deref)

Crash Data

Attachments

(1 file)

See http://bit.ly/iOwn5 ... it looks like Skype might be involved, but we can probably wallpaper over this or fix it in speculative parsing (if that is, in fact, where the bug lies).
Severity: normal → critical
#26 crash for 3.5.3

no crashes reported for 3.0.x releases. 
and doesn't appear for any trunk, beta or alpha builds
Keywords: crash, topcrash
OS: Linux → All
Summary: Topcrash [@ nsScriptLoader::StartLoad ] → Topcrash [@ nsScriptLoader::StartLoad(nsScriptLoadRequest*, nsAString_internal const&)]
Comments mention opening hotmail.  (And definitely correlated with the skype toolbar.)
Flags: blocking1.9.2?
Blake, did you say that we might be able to work around this crash in our code? FWIW, I've been trying pretty hard to reproduce this one, with the Skype extensions installed n' all, but no luck yet. I ran this in a debug build as well, and it seems the Skype extensions don't work right there (it *removes* phone numbers from webpages rather than wrapping them in a clickable link thing), but no crashes or thread safety assertions or anything like that.
Assignee: nobody → mrbkap
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
Target Milestone: --- → mozilla1.9.2
Whiteboard: [crashkill]
Attached patch WallpaperSplinter Review
This is a wallpaper. I don't understand how this crash happens.
Attachment #408116 - Flags: review?(jst)
Comment on attachment 408116 [details] [diff] [review]
Wallpaper

Given that nobody seems to be able to reproduce this, I think we should land this and see what it does for us.
Attachment #408116 - Flags: superreview+
Attachment #408116 - Flags: review?(jst)
Attachment #408116 - Flags: review+
Duplicate of this bug: 524738
Attachment #408116 - Flags: approval1.9.2+
Attachment #408116 - Flags: approval1.9.1.5?
I am not using skype so that is not my problem with the crash. I have had so many different crashes lately. I just wish someone could help me with this. Thanks
Comment on attachment 408116 [details] [diff] [review]
Wallpaper

Approved for 1.9.1.5, a=dveditz for release-drivers
Attachment #408116 - Flags: approval1.9.1.5? → approval1.9.1.5+
Whiteboard: [crashkill] → [sg:dos][crashkill] null deref
Can we get a percentage of crashes that we think this will fix?
Whiteboard: [sg:dos][crashkill] null deref → [sg:dos][crashkill][crashkill-fix] null deref
Whiteboard: [sg:dos][crashkill][crashkill-fix] null deref → [sg:dos][crashkill][crashkill-fix][crashkill-thirdparty] null deref
Depends on: 526058
#14 crash for 3.5.4. 3425 crashes roughly 2 weeks, about 1.6% of crashes
(3.5.4 hasn't been out for a week yet.)

I'm fairly sure this is a lot less than 1.6%. It's closer to 0.8% of crashes overall, last I checked.
I included what I assume is the RC.  I pasted the top 100 into excel (~170k) and guesstimated the count > which tacks on 40k. And from there came up with 1.6% Does the count above rank 100 typically amount to only 1/2 of crashes? Or, how does one get the full total?
Top 100 is ~35% of crashes, but let's not discuss metrics in this bug. Damon wanted an estimate.
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/38c617c0b291
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e13f86ded0df (I finally remembered to fix the bug number typo).
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
I came to this page from the crash page:

http://crash-stats.mozilla.com/report/index/bp-18ccaf0e-03fc-48bb-977f-9957a2091112

(my instance of the dump was on: 2009-11-12 15:38:49.40305 with 3.5.5).

I just wanted to add that there's never been anything Skype-related installed on my machine, so I can't see that the dump would be caused by that.
That build was from two days before (11-02) I landed the fix on the 1.9.1 branch (11-04).
Duplicate of this bug: 531447
Crash Signature: [@ nsScriptLoader::StartLoad(nsScriptLoadRequest*, nsAString_internal const&)]
You need to log in before you can comment on or make changes to this bug.