Crash after creating and destroying "CodeMirror" a javascript code editor component several times.

RESOLVED DUPLICATE of bug 519886

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 519886
9 years ago
9 years ago

People

(Reporter: Ron, Unassigned)

Tracking

3.5 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

A rich application we are developing creates and destroys the codeMirror javascript code editor. After a few cycles thi crashes FF. I've extracted the offending code and put it in the page linked to this bug report. Simply press the button on that page several times to crash Firefox. Note that it sometimes takes a lot of clicks while other times it happens after only a few clicks.

(http://marijn.haverbeke.nl/codemirror/manual.html)

Reproducible: Sometimes

Steps to Reproduce:
1. Load page linked in bug
2. Click repeatedly on the button on that page.
3. Crash.
Actual Results:  
Crash.

Expected Results:  
No Crash.

about:buildconfig

Source

Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/57f71400f4cf
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --with-crashreporter-enable-percent=10
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
Getting a don't hotlink message when opening test url - not sure if that is why I am not getting a crash. Tested ~100 clicks.

Can you provide a crash id (about:crashes) and/or stacktrace? https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

9 years ago
I've fixed the problem that was causing the hotlink error. 

Retrying the crash page after fixing that problem I only had to click 3 times to crash FF.

crash id:

ce7d9422-f92d-4661-a7c6-947312091128

http://crash-stats.mozilla.com/report/index/ce7d9422-f92d-4661-a7c6-947312091128

Comment 3

9 years ago
this was fixed about two days after the build you used.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 519886
You need to log in before you can comment on or make changes to this bug.