Closed Bug 520224 Opened 10 years ago Closed 10 years ago

fix TARGET_XPCOM_ABI for ppc64 and s390(x)

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set

Tracking

(status1.9.2 beta3-fixed)

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta3-fixed

People

(Reporter: wolfiR, Assigned: wolfiR)

References

Details

Attachments

(2 files)

Report from Novell:

TARGET_XPCOM_ABI makes no difference between 32 and 64bit ppc architecture and doesn't recognize s390 and s390x at all.
I don't have access to that type of machines but got a proposed patch from Novell.
Attached patch patchSplinter Review
Patch as I got it from meissner@novell.com
Assignee: nobody → mozilla
Attachment #404296 - Flags: review?(ted.mielczarek)
Comment on attachment 404296 [details] [diff] [review]
patch

The patch looks ok to me, with one nit:
 powerpc* | ppc | rs6000)

You should probably drop the wildcard here, since you're handling powerpc64 above.

I'm not sure how strict we are about XPCOM_ABI bits for tier 2/3 platforms. Is GCC's ABI stable on those archs? Given the variety of other CPU_ARCH statements there, I'm guessing "not very strict".
Attachment #404296 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/3d5fd10b807c
with wildcard removed.

The main reason why the CPU_ARCHS need to get recognized is to allow xul apps (as Firefox) to find the correct XRE for multiarch installations which are common for ppc*/s390* (and x86-64) architectures.
AFAIK gcc's abi is (almost) identical across all platforms since gcc3 at least.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Comment on attachment 404296 [details] [diff] [review]
patch

Basically NPTOB for mozilla but keeps patch count lower for Linux distributions
Attachment #404296 - Flags: approval1.9.2?
Asking wanted-1.9.2 as I'm wondering why that doesn't get approved or denied since weeks.
Flags: wanted1.9.2?
Attachment #404296 - Flags: approval1.9.2? → approval1.9.2+
Comment on attachment 404296 [details] [diff] [review]
patch

Should have just marked this in the first place.
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a1
Attachment #429390 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 429390 [details] [diff] [review]
(Bv1-CC) Copy it to comm-central
[Checkin: Comment 9]


http://hg.mozilla.org/comm-central/rev/803c436845db
Attachment #429390 - Attachment description: (Bv1-CC) Copy it to comm-central → (Bv1-CC) Copy it to comm-central [Checkin: Comment 9]
Duplicate of this bug: 509421
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.