Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Fix jemalloc about:memory reporters on Linux

RESOLVED DUPLICATE of bug 557935

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 557935
8 years ago
7 years ago

People

(Reporter: reed, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

8 years ago
Bug 515354 created a new about:memory page but disabled it on Linux due to some linking issues. Those issues need to be worked out so it can be enabled on Linux. We shouldn't be shipping a feature like this that only works on two of our tier 1 platforms.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
Nomming for blocking1.9.2, as bug 515354 just got approval to land there. Shouldn't ship 1.9.2 with a feature like this that doesn't work at all on a tier 1 platform.
Flags: blocking1.9.2?
Well, bug 515354 isn't blocking, so worst case scenario, if we decide we can't ship about:memory because it's not working on Linux, it looks like we'd just back it out.

-'ing.
Flags: blocking1.9.2? → blocking1.9.2-
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Well, bug 515354 isn't blocking, so worst case scenario, if we decide we can't
> ship about:memory because it's not working on Linux, it looks like we'd just
> back it out.

... and what exactly will ensure that actually happens, whether fixing this bug or backing out about:memory? Seems like you need a blocker bug to ensure this doesn't get forgotten (for whatever choice is made in the end).
No reason to not ship it without it working on Linux; it's not a critical or web compat or anything of the sort feature, and about:memory *works* on Linux, it just doesn't display any values because the malloc reporters aren't hooked up.  If we add new reporters, such as image memory used, those will show up fine on Linux.
Summary: Enable about:memory on Linux → Fix jemalloc about:memory reporters on Linux
And, I'm not sure I'd block the release if we forgot to back out about:memory because it doesn't work as expected/we'd like on Linux.
Still not a blocker.  1.9.3-.
blocking2.0: ? → -
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557935
You need to log in before you can comment on or make changes to this bug.