Show jemalloc stats in about:memory

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

It's a TODO in the current code because of the weird way we link in jemalloc on linux.
Created attachment 437729 [details] [diff] [review]
Report jemalloc stats in about:memory on linux

Note: we could also use libc's mallinfo() for non-jemalloc builds, but I'm not sure that I care about those.
Assignee: nobody → jones.chris.g
Attachment #437729 - Flags: review?(vladimir)
Attachment #437729 - Flags: review?(vladimir) → review+
Comment on attachment 437729 [details] [diff] [review]
Report jemalloc stats in about:memory on linux

ick, but ok!  Can't we cheat and include jemalloc.h anyway?  Worst case we could split up jemalloc.h into jemalloc-structs.h and jemalloc.h so that we could include the structs bit here.  But this is probably ok for now.
Yeah, I thought about splitting the header.  I'll push with that.
http://hg.mozilla.org/mozilla-central/rev/f223c7d06f91 (with split header, ran it by vlad again before pushing)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 520422
You need to log in before you can comment on or make changes to this bug.