When exporting a calendar to CSV the years will be in 2-digits, whereas an HTML and ICS output uses 4-digits for years.

RESOLVED DUPLICATE of bug 550746

Status

Calendar
Import and Export
RESOLVED DUPLICATE of bug 550746
8 years ago
8 years ago

People

(Reporter: silvergrey, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird Versie 2.0.0.23 (20090812) + Lightning 0.9 (both Dutch language)

When exporting a calendar to CSV the years will be in 2-digits, whereas an HTML or ICS output uses 4-digits. This will give problems when using this export file for an import since you don't know the difference between januari 1, 1905 or 2005. Both will show MM/DD/YY.

Regards,
Silvergrey

Reproducible: Always

Steps to Reproduce:
1. optionally create a separate calender just for (test) birthdays.
2. create 2 birthdays: e.g. 3-oct-1906 and one for 3-oct-2006.
3. export the agenda to a CSV file (to ICS and HTML for reference).
Actual Results:  
"Pipo de clown","10/03/06","12:00:00 ","10/04/06","12:00:00 ","True","False","","","Verjaardag","","","False"
"Mamalou","10/03/06","12:00:00 ","10/04/06","12:00:00 ","True","False","","","Verjaardag","","","False"

Expected Results:  
"Pipo de clown","10/03/2006","12:00:00 ","10/04/2006","12:00:00 ","True","False","","","Verjaardag","","","False"
"Mamalou","10/03/1906","12:00:00 ","10/04/1906","12:00:00 ","True","False","","","Verjaardag","","","False"

ICS export file contains:
   DTSTART;VALUE=DATE:19061003
   DTEND;VALUE=DATE:19061004
and
   DTSTART;VALUE=DATE:20061003
   DTEND;VALUE=DATE:20061004

HTML export file contains.
   <abbr class="dtstart" title="19061003">woensdag 3 oktober 1906</abbr>
and
   <abbr class="dtstart" title="20061003">dinsdag 3 oktober 2006</abbr>
I think this is needed for Outlook compatibility. You might want to check out https://addons.mozilla.org/en-US/sunbird/addon/5289

Aside from that, I believe we should provide export options, I've just filed bug 550746 to provide a framework for import/export and mentioned this use case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550746
You need to log in before you can comment on or make changes to this bug.